Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
unable to connect to wifi from some devices
#1
Hello,
Here is Patrick from near Toulouse France.
I beg your pardon for my awfull english.
I am working on an astronomy box which I called NAFA (Nomad Astronomy For All) based on the Tinkerboard. This box is supposed to work standalone with a wifi connection to tablet or PC. The Tinkerboard offers enough power to do so with certain confort. The idea is to have only the Tinkerboard and a tablet or phone or PC to connect to it while it is fixed to the distant astronomy setup. The need is to have minimal setup.
I tested 3 different linux distribution to satisfy the OS need: ARMBIAN, TinkerOS, Lear-system,
Unfortunatelly none of them gives a satisfying wifi stability. Let me explain.
I tried to connect my Dell Latitude E6440 laptop to the board and connection failed during handshake. I put a TP-Link TL-WN722N wifi key and thern it worked.
Same behaviour with my ONDA tablet with Anroid 4.4.4 but there is no added part to help for connection. Otherwise connection worked fine with smartphone using Android 5.1.
I just wanted that future users can use the NAFAbox without any complementary component and it lookks that it is not possible with Tinkerboard today due to those wifi troubles .
I don't know where the problem comes from. Is it the RTL8723BS driver or the network-manager or a specific configuration that I didn't found.
I will be pleased if you can enlight my research for a solution.
Regards
Patrick
Reply
#2
Well, I guess that the first few questions will be :
- Is the board backed by a correct power supply ?
- When having issues with WiFi, are you trying with or without other WiFi devices connected ? Could you give a try without other WiFi devices, if that's the case, see if interferences could be the issue.

Now, do the Tinkerboard and ONDA Tablet use the same WiFi norm ? a/b/g/n ?

Did you try using the board without enclosure ? Does the problem persist ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)