Tinker Board Forum

Full Version: [SOLVED] chromium 70 on TinkerOS (with hardware acceleration)!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Everybody!
It's been a long time since I last posted, But I'm back to fix the annoying problem of chromium 70 on the Tinkerboard!
Backstory: while running an ubuntu chroot on flintos (don't ask), i noticed that chromium 70 worked (but no acceleration).
this made me suspicious that the problem in chromium lay with the Debian build, and that Ubuntu's would work fine on TinkerOS - and I was right!

How to:
first, download the .debs from the following links:
 1: https://launchpad.net/ubuntu/+source/chr..._armhf.deb
2: https://launchpad.net/ubuntu/+source/chr..._armhf.deb
3: https://launchpad.net/ubuntu/+source/chr..._armhf.deb
4: https://launchpad.net/ubuntu/+source/chr..._armhf.deb

then go to the terminal and type sudo apt-get build-dep chromium

then type sudo nano /etc/apt/sources.list and replace all instances of "stretch" with "sid" (save with ctrl+x, y then enter)

then type (might not be necessary) sudo apt-get install fonts-liberation

then go to wherever you downloaded the .debs to and type sudo dpkg -i chromium*.deb

then say "merry christmas and a happy new year" and pat yourself on the back

then type sudo apt-get update

then type sudo apt --fix-broken install (libc6? that's the package we need the sid version of)

finally go back to stretch with sudo nano /etc/apt/sources.list and change all instances of "sid" back to "stretch", save with ctrl+x, y and enter, then type sudo apt-get update

Note: the ubuntu version of chromium is called chromium-browser while Debian's is just chromium, which means that you will now have two seperate installations of chromium on your OS, this is a good thing, because if chromium 70 fails you can easily revert to 67

start chromium 70 with chromium-browser --use-gl=egl



PS: if I've forgotten or messed up something, let me know in the comments!  Cool Big Grin Sleepy

BTW: the terminal command for chromium 67 is simply chromium, while 70's is chromium-browser
Thanks too much.
I can install chromium-browser70, but youtube isn't smooth.
(12-26-2018, 11:59 PM)knifeguy Wrote: [ -> ]Thanks too much.
I can install chromium-browser70, but youtube isn't smooth.

Try installing h264ify from the chrome web store
I'm working on the flags needed to make chromium 70 faster, will update soon  Smile


Also, try going to chrome://flags and enabling "override software rendering list"

Also in flags try changing the number of raster threads to 4