Tinker Board Forum

Full Version: Waveshare 7" Touchscreen
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I can't get a Waveshare 7"" touchsceen display output when connectected to a Tinker Board running TinkerOS_Debian V1.8.

On the RasPi there was a file for configuring the HDMI display when this happened.  Is there equivalent settings for TinkerOS?

Thanks,

Martin
(07-12-2017, 12:29 AM)MartinR Wrote: [ -> ]I can't get a Waveshare 7"" touchsceen display output when connectected to a Tinker Board running TinkerOS_Debian V1.8.
On the RasPi there was a file for configuring the HDMI display when this happened.  Is there equivalent settings for TinkerOS?

I checked RPI thread.
I see following problems:
  1. low quality (need to resolder resistors)
  2. high power load from USB (try to reconnect over external powered hub capable 1A loads or directly from compatible USB power supply/charger)
  3. some problem with EDID (eg. maybe weird data from DCC) and/or with pixel frequency matching
If you resolved 1-2 let's try to resolve 3. Need more information about EDID - try testing section (Step A only) from this post and post output here. If you get EDID output but still not video output you have problem with with pixel frequency matching then you can continue next steps or jump to next post patch (but patch may be insufficient with probability of 50%).
I also have a Waveshare 7"" touchsceen, and it could work with rockchip 4.4 kernel.
https://github.com/rockchip-linux/kernel
The Waveshare display works with other devices.
I am using a powered hub with 3A supply in addition to the USB 2A supply

I just tried TinkerOS Ver 1.9 I did see the boot and get some GUI display, then crash.

I'll try the rockchip 4.4 kernel next.
(07-15-2017, 03:32 AM)MartinR Wrote: [ -> ]The Waveshare display works with other devices.
I am using a powered hub with 3A supply in addition to the USB 2A supply

I just tried TinkerOS Ver 1.9 I did see the boot and get some GUI display, then crash.

I'll try the rockchip 4.4 kernel next.

No Luck with kernel but TinkerOS Ver 1.9beta does work but the display is a little torn up.  Wrong refresh speed?
xrandr works but can't seem to find a refresh rate that xrandr accepts
.
Fixed in latest OS 2.0 beta!
Yes mine works too.  I also have a 3,5inch hat which attaches to the GPIO.  I attached it to the Tinkerboard and it manages to power on, but there is no display.  I looked at the sd card and there are waveshare drivers for 3.2 and 3.5 inch hats.  I wonder if the GPIO pins are different to the Raspberry's and that I need to connect to the different pins?