Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Headless VNC Resolution
#1
I mostly VNC onto my Tinkerboard running it headless. The default screen size appears to be about 1024x768 is there a simple way of forcing the default resolution to something a bit bigger as can be done with config.txt on a Raspberry Pi?
Reply
#2
(03-14-2017, 02:57 PM)djbottrill Wrote: I mostly VNC onto my Tinkerboard running it headless. The default screen size appears to be about 1024x768 is there a simple way of forcing the default resolution to something a bit bigger as can be done with config.txt on a Raspberry Pi?

Hi,

You probably know far more about Debian than me but how did you install a vnc server on the Tinker Board?. I only ask as I tried installing tightvnc server and now a login screen appears on startup but the user name and password don't work.

I'm probably going to have to overwrite the micro sd card with TinkerOS but it would be nice to replicate your vnc server so I could try to fix the default screen size.

Have you tried editing the 'vncserver'.service file in /etc/systemd/system/

ExecStart=/usr/bin/tightvncserver :1

Depending on the vnc server you may be able to set the display parameters on boot up by adding whatever they are to the line beginning with ExecStart (and editing the name of the vnc server appropriately to your choice of server).



Regards

Nick
Reply
#3
I forget where I found the instructions but I'm using Vino Server to provide a VNC remote desktop to my Tinker board.
I think I followed the instructions here:

https://wiki.archlinux.org/index.php/Vino
Reply
#4
I have installed Tight VNC Server to Asus TinkerBoard. However, I found there is NO tight VNC Viewer for macOS ! I tried using Real VNC viewer but it failed to connect to the tight VNC Server in Asus Tinker Board.

Any insights how to resolve this ?
Reply
#5
(05-24-2017, 04:07 PM)wyattwong Wrote: I have installed Tight VNC Server to Asus TinkerBoard. However, I found there is NO tight VNC Viewer for macOS ! I tried using Real VNC viewer but it failed to connect to the tight VNC Server in Asus Tinker Board.

Any insights how to resolve this ?

RealVNC is crap and you need to run the server on the tinker board also, you can't just install it. Tight VNC server for me was also crap, I use x11vnc which can also be run with just x11vnc. I do use Tight VNC client to connect to it with xtightvncviewer xxx.xxx.xxx.xxx
Reply
#6
To connect to tightvncserver on TB I use RealVNC by entering the ip address followed by :1 and it connects.
For example I put xxx.xxx.x.xx:1

My problem is getting tightvncserver to autostart under stretch 2.01
Reply
#7
(03-14-2017, 02:57 PM)djbottrill Wrote: I mostly VNC onto my Tinkerboard running it headless. The default screen size appears to be about 1024x768 is there a simple way of forcing the default resolution to something a bit bigger as can be done with config.txt on a Raspberry Pi?

Have you tried to modify the parameter Sgeometry which is in the /usr/bin/vncserver file ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)