This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No audio
#11
(03-17-2017, 07:35 AM)yi-hsin_hung Wrote:
(03-15-2017, 02:21 PM)Electrohacker Wrote:
(03-15-2017, 09:21 AM)yi-hsin_hung Wrote: What player do you use?

Youtube in the Browser
Hi
   Please help to provide the following infomation to us. Thank a lot!

1. aplay -l
2. cat /proc/asound/cards
3. capture the the following picture to us
    a. open youtube
    b. open "PulseAudio Volume Control --> Playback --> capture"

Got it to work, I had to change the device under playback to rockchip something simethnig.  good that means my board isnt damaged, now I just need to wait for better software support
Reply
#12
Hi,

I installed Tinker OS 1.8 Beta and try to get to work sound to audio Jack but it does not work.

I have just amplifiers connected to audio jack in Tinkerboard without microphone.

I performed this commands:

#apt-get update
#apt-get dist-upgrade

#aplay - I
aplay: playbackv:3224: You need to specify 1 files

#cat /proc/asound/cards

0 [Audio ]: USB-Audio - USB Audio
Generic USB Audio at usb-ff500000.usb-1, high speed
1 [rockchipminiarm] rockchip_miniarm - rockchip, miniarm-codec
rockchip, miniarm-codec


I tried to switch output playback in PulseAudio Volume Control between: Headset-Output / rockchip, miniarm-codec Analog Stereo / USB Audio Analog Stereo
but without success.

I tested audio playback on Chromium on Youtube.com videos.

I do not know what to do. If is something wrong with my Thinkerboard hardware or is needed to setup something in TinkerOS.

I tested this also in TinkerOS 1.4 and 1.6 without success.


Thank you for your help.
Reply
#13
(04-19-2017, 08:02 PM)floch Wrote: Hi,

I installed Tinker OS 1.8 Beta and try to get to work sound to audio Jack but it does not work.

I have just amplifiers connected to audio jack in Tinkerboard without microphone.

I performed this commands:

#apt-get update
#apt-get dist-upgrade

#aplay - I
aplay: playbackv:3224: You need to specify 1 files

#cat /proc/asound/cards

0 [Audio                 ]: USB-Audio  - USB Audio
                                Generic USB Audio at usb-ff500000.usb-1, high speed
1 [rockchipminiarm] rockchip_miniarm - rockchip, miniarm-codec
                                rockchip, miniarm-codec


I tried to switch output playback in PulseAudio Volume Control between: Headset-Output / rockchip, miniarm-codec Analog Stereo / USB Audio Analog Stereo
but without success.

I tested audio playback on Chromium on Youtube.com videos.

I do not know what to do. If is something wrong with my Thinkerboard hardware or is needed to setup something in TinkerOS.

I tested this also in TinkerOS 1.4 and 1.6 without success.


Thank you for your help.

I found you have type error command. 
$aplay -l
(It should be "L" not "I" <-- and use lowercase)

Did you try plug right interface on board as same as interface chose in system?
As frankwu's list. 
(03-12-2017, 09:47 PM)frankwu Wrote: "Headset-Output" is 3.5 AUX Audio Jack

"rockchip.miniarm-codec Analog Stereo" is HDMI Audio

And maybe you need to check each software's Playback.
(because if software has been played, your new output devices's setting will not apply without re-run application)
Reply
#14
Thanks for reply and that you corrected the command

#aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Audio [USB Audio], device 0: USB Audio [USB Audio]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 0: Audio [USB Audio], device 1: USB Audio [USB Audio #1]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 0: Audio [USB Audio], device 2: USB Audio [USB Audio #2]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 1: rockchipminiarm [rockchip,miniarm-codec], device 0: ff890000.i2s-i2s-hifi i2s-hifi-0 []
 Subdevices: 1/1
 Subdevice #0: subdevice #0


"Did you try plug right interface on board as same as interface chose in system?"

I do not know how to do it. I pluged speaker cable to audio jack on Tinkerboard.


From software side I tried just to setup PulseAudio Volume Control to Headset-Output. I do not know how to join PusleAudio Volume Control to 3.5 AUX AudioJack.
Reply
#15
Is here someone who have running sound on USB Audio Analog Stereo on 3.5 AUX Audiojack under TinkerOS ?

I
Reply
#16
(04-20-2017, 12:53 PM)floch Wrote: Thanks for reply and that you corrected the command

#aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Audio [USB Audio], device 0: USB Audio [USB Audio]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 0: Audio [USB Audio], device 1: USB Audio [USB Audio #1]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 0: Audio [USB Audio], device 2: USB Audio [USB Audio #2]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 1: rockchipminiarm [rockchip,miniarm-codec], device 0: ff890000.i2s-i2s-hifi i2s-hifi-0 []
 Subdevices: 1/1
 Subdevice #0: subdevice #0


"Did you try plug right interface on board as same as interface chose in system?"

I do not know how to do it. I pluged speaker cable to audio jack on Tinkerboard.


From software side I tried just to setup PulseAudio Volume Control to Headset-Output. I do not know how to join PusleAudio Volume Control to 3.5 AUX AudioJack.

If you plug audio cable to audio jack (3.5 AUX Audio Jack).
You need to set default interface with Headset-Output in PulseAudio Volume Control.
Reply
#17
Yes, I did, but without affect.

I can not also boot Android. The screen remain black.

I have some of the first Tinkerboard hardware. On PCB it is said than it is Thinker Board rev 1.2. What Revision have you ?

Thanks.
Reply
#18
(04-23-2017, 12:25 PM)floch Wrote: Yes, I did, but without affect.

I can not also boot Android. The screen remain black.

I have some of the first Tinkerboard hardware. On PCB it is said than it is Thinker Board rev 1.2. What Revision have you ?

Thanks.


Hi my board version same as v1.2.
Maybe need more try...

BTW, I also can boot android. What kind SD card as you used? 
Maybe is SD card speed not support very well.
Reply
#19
(04-23-2017, 12:25 PM)floch Wrote: I have some of the first Tinkerboard hardware. On PCB it is said than it is Thinker Board rev 1.2. What Revision have you ?
I think that all have rev 1.2.
You can try to test low level with ALSA (also check "alsamixer" for muted) :
Code:
# aplay -L | grep plughw
plughw:CARD=Audio,DEV=0
plughw:CARD=Audio,DEV=1
plughw:CARD=Audio,DEV=2
plughw:CARD=rockchipminiarm,DEV=0

# speaker-test -Dplughw:CARD=Audio,DEV=2
I left this community in Aug 2017 due to ASUS bad product quality and ASUS community support that did not match my expectation.  Sad
Reply
#20
(04-23-2017, 01:18 PM)frankwu Wrote: Hi my board version same as v1.2.
Maybe need more try...

BTW, I also can boot android. What kind SD card as you used? 
Maybe is SD card speed not support very well.

Thanks for answer.

I have 32 GB Kingstone SD card class 10. I do not think that the problem is in SD card because I flashed TinkerOS on this SD card and it works fine, only no audio.

I really do not know why I can not boot Android and TinkerOS I can from same SD card. I tried boot Android 3 times and one time I wait 4 hours to boot and withouth affect. I followed instructions from ASUS and flashed Android image on SD card from SD_Firmware_Tool.exe.

(04-23-2017, 01:19 PM)mcerveny Wrote:
(04-23-2017, 12:25 PM)floch Wrote: I have some of the first Tinkerboard hardware. On PCB it is said than it is Thinker Board rev 1.2. What Revision have you ?
I thing that all have rev 1.2.
You can try to test low level with ALSA (also check "alsamixer" for muted) :
Code:
# aplay -L | grep plughw
plughw:CARD=Audio,DEV=0
plughw:CARD=Audio,DEV=1
plughw:CARD=Audio,DEV=2
plughw:CARD=rockchipminiarm,DEV=0

# speaker-test -Dplughw:CARD=Audio,DEV=2

Thanks.

I tested your speaker-test and I am still with no soud.

I checked alsamixer and option F6 and found that I do not have setup default sound card. Options are USB Audio and rockchip. 

 I do not know how to do it, to setup default sound card to USB Audio. I hoped that it do PulseAudio Control, but it did not work.



It seems that TinkerOS is not fully configured.

I can not find:

cat /proc/asound/modules

/etc/modprobe.d/alsa-base.conf

/etc/asound.conf


command pacmd does not works.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)