This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Did I kill it? :(

So, I recently got a Tinker Board S as a Christmas gift.  Pretty exciting!  I've been contemplating getting one for a while, because I've been wanting to see how well it does at three functions:

1)  Retropie console
2)  Kodi (I have a TV server in my home that runs Kodi/NextPVR and the NextPVR Kodi plugin with 6 CableCard tuners and I wanted to see how well the TB S could handle it)
3)  Minecraft server

So anyway ... I bought a quality 5V 3A microUSB power supply and a 64GB SD card for it.  I downloaded an Armbian-based image (can provide the link to the thread after I make a few posts on here it looks like) and was successful in connecting the TB to my Windows 10 PC and using Etcher to flash the image onto the embedded eMMC storage.

I think that is where this all went sideways on me.  After flashing the image, I unplugged the TB from my Win10 PC, connected a mouse/keyboard and a monitor via HDMI, and my microUSB power supply.  The power supply has a power switch on it, so I turned it on.  The "No signal" on my monitor went away as expected, but the screen stayed black.  I had heard that this sometimes happens, and to just give it some time, so I left it powered on overnight.

Still nothing this morning.  HDMI signal appears to be there, but the screen is full black.  The red light on the TB is on solid, and the amber light is blinking like a heartbeat.

Thinking maybe the Armbian image I downloaded wasn't working, I disconnected the TB and downloaded an official image off the ASUS website.  I then connected the TB to my Windows 10 PC via the same USB cable I used the first time, and after powering on for a few seconds, the red light goes out.  After trying it a few more times (including with a different cable and a different PC), nothing changed.

I flipped the jumper over to attempt eMMC recovery, but in that state, there's still no HDMI output and no light activity except the red light staying on solid.  My computer does not detect that a USB device is plugged in at all.

Did I kill it?


Thank you in advance,
Did you read this or this ?
Light blue words might be a link. Have you try to click on them? Big Grin

Thanks for the response.

I checked the links you provided and was able to get the TBS to boot from the SD card's TinkerOS image. However, I can only do this using my power adapter. If I try to boot the TBS using a USB cable plugged into a USB 2.0 or 3.0 port on my Windows 10 PC, the TBS stays powered on for a few seconds, then powers off. This is with Maskrom mode turned on via jumper.

At least I know it's not bricked. But I have no idea how I can get a working image on the eMMC now.

Any other thoughts on this? I appreciate the help!

Oh my dear, don't you know the Asus recommendations ?
They're telling a power supply of 2.5 Amps. The latest USB port might give 1 Amps maximum and is the weird idea to go trough that supplying mode. Because the hardware will automatically cap at 300 mA. Therefore don't be surprise if you'll get hiccups like a car without fuel Smile
Light blue words might be a link. Have you try to click on them? Big Grin
Are you saying then, that I should use the 3A microUSB power supply in the microUSB port, and connect the TBS to my computer using one of the regular USB ports? I was presuming that would not work, but if I am wrong, problem solved!
Well, I just tried providing the TBS power via a modded 5v/3a power supply via the GPIO pins. This powered the TBS fine, and it booted to a desktop. However, then connecting the microUSB port to my computer via USB cable did nothing at all.

So you're supposed to set the jumper to Maskrom mode, plug in a bootable SD card, then plug the TBS into a computer via microUSB. But the TBS won't stay powered on via the power from a computer's USB port ... so how are you supposed to recover the eMMC that way?

Something does not add up here.
I suppose that you shouldn't have both connected during boot time (micro USB or GPIO and USB port). It's a condition that has blown my WiFi dongle as well.
If you need a communication to the PC you should connect the PC after booting.
Asus has a recommended one, which it may give you the figure how it should look like.

The power supply through the micro USB is the recommended one, which has all the protection scheme. The GPIO pins are bidirectional, but they are unprotected. Also the 5 V from the USB should be going through across the protecting hardware and limit the output current to 300 mA (nothing is known about input from there). But I suspect that the protection may not be set until the kernel will take control.

If you chew some electronic knowledge, you might look at the schematics

But you consider that if the power lacks to provide enough amps on the startup it will repeatedly reboot. See here

The line has several glitches that are lower than enough, so the machine is at risk to reboot.
Light blue words might be a link. Have you try to click on them? Big Grin

I appreciate your responses. But you say:

(01-08-2019, 05:13 AM)Im4Tinker Wrote: If you need a communication to the PC you should connect the PC after booting.

I don't understand how I am supposed to do that. How can one use the microUSB for power via a microUSB power adapter, AND connect to PC via microUSB? It's a one-or-the-other affair here. Am I misunderstanding you?

Thank you again.
(01-08-2019, 11:30 AM)Ark :D Wrote: How can one use the microUSB for power via a microUSB power adapter

Maybe I wasn't clear. There must be just one power source during boot time. So when it's planned to read the eMMC we can connect the micro USB to a PC, but when is supposed to run a full blow of OS, the PC can't give enough power.

When it's supposed to have a share between TB and PC, via one of the 4 USB ports, first boot the TB (powered by micro USB or GPIO) then later connect the PC.

Plugging power on micro USB and supply by GPIO pins is the highest risk that something wrong may happen, I think.
Light blue words might be a link. Have you try to click on them? Big Grin
Because we let user can have a easy way to flash eMMC.
So if your Tinker Board S plug with micro-USB to your PC, it would not be boot into system.
It would going to UMS mode, let your PC can see a flash drive.

That may is why you can not boot up, and also the USB from PC, it's power would not enough to provide whole system loading.

Forum Jump:

Users browsing this thread: 1 Guest(s)