This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Armbian CSI Cam
#1
I try to get work csi camera picam v2.1(IMX219), but i don't have any /dev/video on login. So i found there no bcm2835-v4l2. I try to enable the modules, not found in the kernel :/ damn. I try to add/find the bcm2835-v4l2 from https://github.com/rockchip-linux/kernel and https://github.com/TinkerBoard/debian_kernel. not working i can,t use the command modprobe each time he try to find the module in the module directory where i added the .ko file(i try bcm2835/bcm2835.ko too...).

My project is a remote control robot through wireless network with webrtc on firefox(maybe chromium too). I use javascript too for the keybinding to control the robot from the webpage with peerjs, maybe i gonna add a controler like Xbox Natively embed in web browser  Smile , but for this time it's just the arrow on the keyboard.
my projet was working on a raspberry pi but the cpu was ... and can't get enough Fps(maybe h264 4 the win x) ) so i buy a tinkerboard.

my question is do i need to trash the picam ... and buy a usb cam, because i try to get this work for a while or can some one help me to solve this probleme thanks !

for now i am on armbian because it's clearly better, but no csi cam driver by default :/ . I can fall back on tinkeros but can some one help me because the last time i cannot get work the csi cam on tinkeros too, and by default i have a display probleme with frequensy ... need to add some line in xorg config to get it display something on tinkeros 2.0.4 it's really cool(joke).

the webcam need to work on this testing page https://test.webrtc.org/

sorry my english can be bad some time :p
Reply
#2
I change for a usb cam for now but if some one solve this probleme thanks to reply at this thread.
Reply
#3
Have you already read the CSI tutorial on the tinkerboarding wiki page?
This tutorial explains how to install the camera on your Tinker Board and it shows a few examples on how to test the camera. The tutorial is ment for the camera sensors IMX219 and OV5647 so it should work for the picamera v2.

https://tinkerboarding.co.uk/wiki/index.php?title=CSI-camera
Reply
#4
Yeah I already try and was not working on webrowser because the camera is not supported for web browser i think.
and I am on armbian for now it's more stable for now, I wait for a new update of tinkeros and maybe a github repository where the comunity can work on it...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)