This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SSH port change not persistant.
#1
I am running TinkerOS 2.0.5 up to date.
When I change to ssh port for a custom port I work well, but when I reboot the ssh port go back to 22 even if it's 2222 in the config.

Anyone have a clue?
Reply
#2
I am at 2.0.4 and setting port in /etc/ssh/sshd_config does the trick.
Reply
#3
(05-09-2018, 12:30 AM)ilevac Wrote: I am running TinkerOS 2.0.5 up to date.
When I change to ssh port for a custom port I work well, but when I reboot the ssh port go back to 22 even if it's 2222 in the config.

Anyone have a clue?

hi ilevac,

I change the ssh daemon setting and it works. The custom port setting will apply successfully after reboot.

$ sudo vim /lib/systemd/system/ssh.socket
Code:
[Unit]
Description=OpenBSD Secure Shell server socket
Before=ssh.service
Conflicts=ssh.service
ConditionPathExists=!/etc/ssh/sshd_not_to_be_run

[Socket]
ListenStream=2222
Accept=yes

[Install]
WantedBy=sockets.target
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)