This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to enable VNC at startup? Disables itself on reboot...
#1
Hey guys, is it possible to enable VNC at startup?
I went to the tinkerboard settings and activated VNC and set up a password... and it works - But whenever I reboot my Tinker Board it disables VNC by default...

Is there anything I can do to keep it active by default?

Thanks,
vila4480
Reply
#2
(05-14-2018, 02:25 AM)vila4480 Wrote: Hey guys, is it possible to enable VNC at startup?
I went to the tinkerboard settings and activated VNC and set up a password... and it works - But whenever I reboot my Tinker Board it disables VNC by default...

Is there anything I can do to keep it active by default?

Thanks,
vila4480

Hi vila4480,

The following steps are my method to make vnc start at boot. You can have a try.

1. Setting vnc password
$ vncpasswd

2. Create a tightvncserver daemon
$ sudo vim /lib/systemd/system/tightvncserver.service
Code:
[Unit]
Description=TightVNC Server
After=sshd.service network.target

[Service]
Type=forking
User=linaro
ExecStartPre=-/usr/bin/tightvncserver -kill :1 > /dev/null 2>&1
ExecStart=/usr/bin/tightvncserver :1
ExecStop=/usr/bin/tightvncserver -kill :1
[Install]
WantedBy=multi-user.target

3. Enable and start tightvncserver daemon
$ sudo systemctl enable tightvncserver.service
$ sudo systemctl start tightvncserver.service

Be aware to setting vnc password before enable tightvncserver daemon, or it will fail to start
Reply
#3

Thank you very much, miki1778 - I'll try it out soon and I'll come back to post a new reply.
Thanks!
Reply
#4
(05-31-2018, 12:18 PM)miki1778 Wrote: .

I'm sorry for the delay in this reply but unfortunately I had to be away for some time.
I managed to do all the steps you mentioned and I did set the password BEFORE doing anything after as you mentioned.
However I'm getting this error message when executing the last command... any idea whats going on here?

[Image: image-2666531501800044.png]

Thank you for your support!
-ViLa
Reply
#5
Hi ViLa,

It seems to fail at executing the command "/usr/bin/tightvncserver :1"
Do you have tightvncserver in your system?
$ sudo apt-get install tightvncserver

-Miki
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)