This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ELAR Systems Lubuntu 18.04 image and Ethernet problems
#1
I'm giving the Tinker Board a try with the ELAR Systems Lubuntu 18.04 (Ver 2.0) image.  I can get WiFi working fine, but I can't figure out how to get a functioning ethernet connection to my local LAN.

Must be missing something simple Huh , but I just can't figure out what.  Using ethtool I can see the Ethernet device exists in the kernel, but its returning a 'Device or resource busy' error.

Code:
$ ethtool eth0
Settings for eth0:
Cannot get device settings: Device or resource busy
Cannot get wake-on-lan settings: Operation not permitted
Cannot get message level: Device or resource busy
Cannot get link status: Device or resource busy
No data available

Any ideas on things I should be checking to get Ethernet working?

Thanks,

Mike

Just some more information.  Using lshw utility, I get the following:

Code:
sudo lshw -C network
  *-network:0               
       description: Wireless interface
       physical id: 4
       logical name: wlan0
       serial: 40:9f:38:4e:fc:cf
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723bs ip=192.168.1.236 multicast=yes wireless=IEEE 802.11bgn
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 5
       logical name: eth0
       serial: 88:d7:f6:c2:bc:90
       capabilities: ethernet physical
       configuration: broadcast=yes multicast=yes

This indicates the Ethernet interface is indeed disabled.  Now to figure out how to enable it.

Mike

Sorry, for wasting people's time.  The following got things going for me.


Code:
$ sudo apt-get install net-tools
$ sudo ifconfig eth0 up

lshw and ifconfig both report the interface is now enabled.

I suspect there is a newer/better way to do this in the latest versions of Ubuntu, but I'm use to the older ifconfig styles tools.
Reply
#2
Ubuntu 18.04 uses netplan to control network interfaces

You need to tell netplan to use NetworkManager as renderer:

create a yaml file inside /etc/netplan, the name is not relevant, could be: default.yaml, put inside this code
Code:
network:
  version: 2
  renderer: NetworkManager
then run
Code:
netplan generate
netplan apply
systemctl restart NetworkManager
You can now configure eth0 using the desktop applet as usual, or nmtui on bash



(05-17-2018, 10:30 PM)mpthompson Wrote: I'm giving the Tinker Board a try with the ELAR Systems Lubuntu 18.04 (Ver 2.0) image.  I can get WiFi working fine, but I can't figure out how to get a functioning ethernet connection to my local LAN.

Must be missing something simple Huh , but I just can't figure out what.  Using ethtool I can see the Ethernet device exists in the kernel, but its returning a 'Device or resource busy' error.

Code:
$ ethtool eth0
Settings for eth0:
Cannot get device settings: Device or resource busy
Cannot get wake-on-lan settings: Operation not permitted
Cannot get message level: Device or resource busy
Cannot get link status: Device or resource busy
No data available

Any ideas on things I should be checking to get Ethernet working?

Thanks,

Mike

Just some more information.  Using lshw utility, I get the following:

Code:
sudo lshw -C network
  *-network:0               
       description: Wireless interface
       physical id: 4
       logical name: wlan0
       serial: 40:9f:38:4e:fc:cf
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723bs ip=192.168.1.236 multicast=yes wireless=IEEE 802.11bgn
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 5
       logical name: eth0
       serial: 88:d7:f6:c2:bc:90
       capabilities: ethernet physical
       configuration: broadcast=yes multicast=yes

This indicates the Ethernet interface is indeed disabled.  Now to figure out how to enable it.

Mike

Sorry, for wasting people's time.  The following got things going for me.


Code:
$ sudo apt-get install net-tools
$ sudo ifconfig eth0 up

lshw and ifconfig both report the interface is now enabled.

I suspect there is a newer/better way to do this in the latest versions of Ubuntu, but I'm use to the older ifconfig styles tools.
Reply
#3
Same issue. I put all the following and it is working for me (may be only the last one is needed, I don't know, I tried #1, didn't work, added #2, didn't work, added #3 worked)
-------------#1------------------------
sudo nano /etc/NetworkManager/NetworkManager.conf
change the line managed=false to managed=true
Save, stop and start network manager:
sudo service network-manager restart
------------#2----------------------
sudo nano /etc/network/interfaces
(The file only has comments in it)
add:
auto lo
iface lo inet loopback
Save, stop and start network manager:
sudo service network-manager restart
-------------#3 (try this one first, may be #1 and #2 are not needed----------------------
sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
Reply
#4
hi dmnhieu,
Not sure if this will help u..
but when i was trying to get
TinkerOS_Debian V2.0.7 working with docker..

(fix IP) LAN [dns  8.8.8.8,8.8.4.4 search 192.168.0.1]
-----------------------------------------------------------------
>sudo nano /etc/dhcpcd.conf   ### add to eof ####
------------------------------------------------------------------
# Set Static IP for eth0
nohook lookup-hostname
interface eth0
static ip_address=192.168.0.21/24
static routers=192.168.0.1
static domain_name_servers=8.8.8.8 4.4.4.4 192.168.0.1
static domain_search=192.168.0.1
static domain_name=192.168.0.1
#static domain_search=example.com
#static domain_name=example.com
-------------------------------------------
hope it helps,
k.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)