This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gstreamer and hardware decoding
#1
Hi, I want to use Gstreamer to play videos in 4K with hardware decoding. I'm currently testing different commands with gst-launch such as:

gst-launch-1.0 filesrc location=~/Downloads/test.mp4 ! decodebin ! videoconvert ! xvimagesink

or

gst-launch-1.0 playbin uri=file:///home/linaro/Downloads/test.mp4


Both play the video (4K video) but in 5fps more or less, so i'm guessing that hardware decoding isn't being used, because if I use the native media player the video plays just fine.

Any idea of the problem? I have also tried other pipelines using different elements such as mppvideodec with no result

Thanks!
Reply
#2
Haha,

I may know this how to work!!
try rkximagesink!!

I don't know what are they different. but I saw something like at https://github.com/rockchip-linux/gstreamer-rockchip-extra before.
Reply
#3
Hi, thanks for answering
I have tried this commands:

gst-launch-1.0 filesrc location=~/Downloads/test.mp4 ! decodebin name=decoder decoder. ! queue ! videoconvert ! rkximagesink
gst-launch-1.0 filesrc location=~/Downloads/test.mp4 ! decodebin ! videoconvert ! rkximagesink
gst-launch-1.0 uridecodebin uri=file:~/Downloads/test.mp4 ! rkximagesink

The three of them work much better than before, however only the first one works almost smoothly. I think the video lags from time to time since videoconvert uses a lot of cpu, am I right?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)