This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
vnc+linaro+permission
#1
Hi

(1)
I've enabled the vnc and connected to tinker board successfully. but after first connection i cannot login to linaro user from the main monitor which is connected to hdmi port. what is the problem?
(2)
When i connect to tinker from vnc viewer the permission to some feature such as enabling wifi is restricted.(message: Not authorized to control networking. How can i fix it?

Thanks.
Reply
#2
Hi Mreza1367,

(1) It's a weird condition. What happened when you try to login? password error?
(2) Try the command "sudo rfkill unblock wifi" to enable wifi. It works for me!
Reply
#3
(06-11-2018, 03:54 AM)miki1778 Wrote: Hi Mreza1367,

(1) It's a weird condition. What happened when you try to login? password error?
(2) Try the command "sudo rfkill unblock wifi" to enable wifi. It works for me!

Thanks for the answer.
Actually It try to login, the screen get off, after about 2 sec again the login window apear!
Reply
#4
Oh! Maybe I know what happened to you. I have encountered a situation like this before.
Which command you used to enable vnc?
I have enabled the vnc server as root. like this:
$ sudo vncserver
When setting the password of vnc, the system modified the file /home/linaro/.Xauthority and make its owner become root.
User "linaro" can't read the .Xauthority file caused the login issue.

The following steps are how I fix it
1. Login in console mode using ctrl + alt + F1
2. remove .Xauthority file
$ sudo rm /home/linaro/.Xauthority
3. Login in Desktop mode using ctrl + alt + F7
Reply
#5
(06-11-2018, 07:09 AM)miki1778 Wrote: Oh! Maybe I know what happened to you. I have encountered a situation like this before.
Which command you used to enable vnc?
I have enabled the vnc server as root. like this:
$ sudo vncserver
When setting the password of vnc, the system modified the file /home/linaro/.Xauthority and make its owner become root.
User "linaro" can't read the .Xauthority file caused the login issue.

The following steps are how I fix it
1. Login in console mode using ctrl + alt + F1
2. remove .Xauthority file
$ sudo rm /home/linaro/.Xauthority
3. Login in Desktop mode using ctrl + alt + F7

Yes you are right. I remember that i enabled the vnc server as root. Cool
I'll test the steps.
Thanks alot miki.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)