This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using X11VNC and Allowing Access By All External/Remote Networks
#1
Hi all. I'm new here. I'm working with a Tinkerboard and have X11VNC working perfectly as a direct connection (over the same wifi).

I would like to be able to access my board from anywhere in the world, but when I attempt to access from other networks I get an error message.

I am assuming this has to do with my router not forwarding the correct port to the tinkerboard.

Is there a workaround for this ? Something involving Ngrok perhaps? I'm not really great at this kind of thing but currently I have it opening on boot.

Let me know if you need me to provide anything.

I am NOT looking to do SSH tunneling currently ( I am aware of the safety risks ).

I am running newest version of debian.

Thanks!
Reply
#2
The number you need to port forward is port 5900
Reply
#3
(07-22-2018, 06:45 PM)tinkerthis Wrote: The number you need to port forward is port 5900



From what I can remember.

1 set apps/games port forwarding ip for linaro computer and port 5900
2 google what is my ip   connect with your wan ip    64.1.234.2:5900

The wan can change and some providers may block vnc.  If so, maybe use a vpn.

The wan is the phone number to your business building or home and the port 5900 is the extension number to your linaro computer.
Reply
#4
Hey Everyone, 
I installed x11vnc on my tinkerOS. I set the autostart by adding "@x11vnc -forever -usepw" to the last line of ~/.config/lxsession/LXDE/autostart file (going through the GUI doing manually). But, now when i connect to it, i get a new desktop and not the active one. The primary desktop is seen idle on the hdmi output of the board and there is another desktop running in vnc. I tried adding command -display :0, but it isn't working. Everytime it gets connected to tinkerboard:1 while I believe my primary desktop is tinkerboard:0. This problem doesn't occur when i am starting the x11vnc manually and not with the autostart.

I need to sort this quickly in order to complete my project. Thanks in advance!
Reply
#5
(01-16-2019, 01:29 PM)KeviN Wrote: Hey Everyone, 
I installed x11vnc on my tinkerOS. I set the autostart by adding "@x11vnc -forever -usepw" to the last line of ~/.config/lxsession/LXDE/autostart file (going through the GUI doing manually). But, now when i connect to it, i get a new desktop and not the active one. The primary desktop is seen idle on the hdmi output of the board and there is another desktop running in vnc. I tried adding command -display :0, but it isn't working. Everytime it gets connected to tinkerboard:1 while I believe my primary desktop is tinkerboard:0. This problem doesn't occur when i am starting the x11vnc manually and not with the autostart.

I need to sort this quickly in order to complete my project. Thanks in advance!


You have some options.
Tightvnc, Tigervnc or Vino.
Do a search for them in synaptic.

Maybe x11vnc has an issue.

What client you using and how are you connecting? 
I having used vnc for many years.  I'll play around with it get back if I find something.
Wait and see if others respond.
Reply
#6
(01-16-2019, 01:29 PM)KeviN Wrote: Hey Everyone, 
I installed x11vnc on my tinkerOS
Do not crosspost, it's misleading.

Take one discussion and stick to that. So you had an answer
Light blue words might be a link. Have you try to click on them? Big Grin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)