This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Volume Control does nothing
#11
(08-07-2018, 01:53 AM)Smiley85 Wrote:
(08-04-2018, 01:52 PM)Tinkard_Boer Wrote: I've got the same problem. The volume control on the system tray moves up and down, but does not adjust the volume. I have to open the PulseAudio volume control program to change the volume. Can't adjust it from the volume keys on my keyboard on this 2.0.7 version of TinkerOS. The keyboard does adjust the volume setting on the system tray, but it does not affect the volume at all.

I reinstall and yup still having this issue as well.

(08-03-2018, 05:21 PM)Im4Tinker Wrote: Discovering the problem may improve your skill, rather than reinstalling.
I suggest you to use a /home partition, so your setting and data won't disappear all together.

I'm not that savy with linux.

(08-03-2018, 10:01 AM)dom_m Wrote: I have the same problem from time to time. I just right click on the volume icon, select 'Launch Mixer', find the output device ("rockchip-miniarm-codec" is sound to HDMI) and adjust from there.

When I do this, the sound comes through my monitor. I would perfer if it came through my speakers.


TinkerboardOS v207:
1 Plug in your speakers into the earphone jack
2 Run a youtube video
3 Go to menu>soundVideo>pulseAudio>PlayBack Tab>
   You should see the volume level movement.
4 Select the drop down button and select head set out.

Is that what you are asking for?
Reply
#12
(08-07-2018, 06:13 AM)Jay Smith Wrote:
(08-07-2018, 01:53 AM)Smiley85 Wrote:
(08-04-2018, 01:52 PM)Tinkard_Boer Wrote: I've got the same problem. The volume control on the system tray moves up and down, but does not adjust the volume. I have to open the PulseAudio volume control program to change the volume. Can't adjust it from the volume keys on my keyboard on this 2.0.7 version of TinkerOS. The keyboard does adjust the volume setting on the system tray, but it does not affect the volume at all.

I reinstall and yup still having this issue as well.

(08-03-2018, 05:21 PM)Im4Tinker Wrote: Discovering the problem may improve your skill, rather than reinstalling.
I suggest you to use a /home partition, so your setting and data won't disappear all together.

I'm not that savy with linux.

(08-03-2018, 10:01 AM)dom_m Wrote: I have the same problem from time to time. I just right click on the volume icon, select 'Launch Mixer', find the output device ("rockchip-miniarm-codec" is sound to HDMI) and adjust from there.

When I do this, the sound comes through my monitor. I would perfer if it came through my speakers.


TinkerboardOS v207:
1 Plug in your speakers into the earphone jack
2 Run a youtube video
3 Go to menu>soundVideo>pulseAudio>PlayBack Tab>
   You should see the volume level movement.
4 Select the drop down button and select head set out.

Is that what you are asking for?

Hi,

No that's not exactly what I'm asking for. I'm trying to get the bottom right volume icon to work instead of having to go through the pulse audio menu. I'm using the Tinkerboard as a kids computer so that method would be too complicated.
Reply
#13
(08-17-2018, 10:55 PM)Smiley85 Wrote:
(08-07-2018, 06:13 AM)Jay Smith Wrote:
(08-07-2018, 01:53 AM)Smiley85 Wrote:
(08-04-2018, 01:52 PM)Tinkard_Boer Wrote: I've got the same problem. The volume control on the system tray moves up and down, but does not adjust the volume. I have to open the PulseAudio volume control program to change the volume. Can't adjust it from the volume keys on my keyboard on this 2.0.7 version of TinkerOS. The keyboard does adjust the volume setting on the system tray, but it does not affect the volume at all.

I reinstall and yup still having this issue as well.

(08-03-2018, 05:21 PM)Im4Tinker Wrote: Discovering the problem may improve your skill, rather than reinstalling.
I suggest you to use a /home partition, so your setting and data won't disappear all together.

I'm not that savy with linux.

(08-03-2018, 10:01 AM)dom_m Wrote: I have the same problem from time to time. I just right click on the volume icon, select 'Launch Mixer', find the output device ("rockchip-miniarm-codec" is sound to HDMI) and adjust from there.

When I do this, the sound comes through my monitor. I would perfer if it came through my speakers.


TinkerboardOS v207:
1 Plug in your speakers into the earphone jack
2 Run a youtube video
3 Go to menu>soundVideo>pulseAudio>PlayBack Tab>
   You should see the volume level movement.
4 Select the drop down button and select head set out.

Is that what you are asking for?

Hi,

No that's not exactly what I'm asking for. I'm trying to get the bottom right volume icon to work instead of having to go through the pulse audio menu. I'm using the Tinkerboard as a kids computer so that method would be too complicated.



Install kmix
Go to the menu and sound and click kmix.
The icon doesn't stay in the taskbar. Need to find out how to keep it at bootup.

No autostart is not working.
Go to .config then open with an editor autostart and at the bottom type @kmix 
I think that should work.
Reply
#14
I also encounter this problem (I am a new user of the Tinkerboard S) with Tinker OS 2.0.7. I find that first, unplug the 3.5mm speakers/earphones, then removing the volume control from the panel (right click on the task bar in the bottom of the screen, select "Add remove items" etc... ), reboot, right click on the task bar, select "Add remove items" etc... to add back the volume slider, plug back in the 3.5mm earphone/speakers works again. From time to time, the volume slide would fail to work again and I need to repeat this procedure.
Reply
#15
(09-04-2018, 07:54 AM)dmnhieu Wrote: I also encounter this problem (I am a new user of the Tinkerboard S) with Tinker OS 2.0.7. I find that first, unplug the 3.5mm speakers/earphones, then removing the volume control from the panel (right click on the task bar in the bottom of the screen, select "Add remove items" etc... ), reboot, right click on the task bar, select "Add remove items" etc... to add back the volume slider, plug back in the 3.5mm earphone/speakers works again. From time to time, the volume slide would fail to work again and I need to repeat this procedure.

I try your method and it did not work for me.

I might just revert back to 2.03 until there's a fixed to this.
Reply
#16
(09-04-2018, 07:54 AM)dmnhieu Wrote: I also encounter this problem (I am a new user of the Tinkerboard S) with Tinker OS 2.0.7.  I find that first, unplug the 3.5mm speakers/earphones, then removing the volume control from the panel (right click on the task bar in the bottom of the screen, select "Add remove items" etc... ), reboot, right click on the task bar, select "Add remove items" etc... to add back the volume slider, plug back in the 3.5mm earphone/speakers works again.  From time to time, the volume slide would fail to work again and I need to repeat this procedure.

Hi,


I think that you can try this:


sudo tinker-config

Interfacing Options -> Audio -> Force 3.5mm

then reboot, and you can use the volume control on the task bar.
[-] The following 1 user Likes Ewan's post:
  • Smiley85
Reply
#17
P
(09-11-2018, 02:41 AM)Ewan Wrote:
(09-04-2018, 07:54 AM)dmnhieu Wrote: I also encounter this problem (I am a new user of the Tinkerboard S) with Tinker OS 2.0.7.  I find that first, unplug the 3.5mm speakers/earphones, then removing the volume control from the panel (right click on the task bar in the bottom of the screen, select "Add remove items" etc... ), reboot, right click on the task bar, select "Add remove items" etc... to add back the volume slider, plug back in the 3.5mm earphone/speakers works again.  From time to time, the volume slide would fail to work again and I need to repeat this procedure.

Hi,


I think that you can try this:


sudo tinker-config

Interfacing Options -> Audio -> Force 3.5mm

then reboot, and you can use the volume control on the task bar.

Thank you that worked!
Reply
#18
It does not seem to help to use this method to control hdmi volume using the slider. Any ideas?

Regards
Reply
#19
(04-05-2019, 02:55 PM)StormingMeccanoMan Wrote: It does not seem to help to use this method to control hdmi volume using the slider.  Any ideas?

Regards

You can look at this and remember to re-edit, if it causes you problems.
Note: This maybe out dated. I don't want to mess with my HDMI Volume Control as it has been working for some time.


The volume control depends on what PulseAudio default sink when it starts.
You can set default sink at /etc/pulse/default.pa:
set to HDMI
set-default-sink alsa_output.platform-sound-simple-card.analog-stereo
set to 3.5mm
set--default-sink alsa_output.hw_0_2
After setting, you MUST restart PulseAudio:
pulseaudio --kill
pulseaudio --start

Previously, mine was somehow set to 'set-default-sink alsa_output.platform-sound.analog-stereo'.



This is the last line in my etc/pulse/default.pa

### Make some devices default
#set-default-sink output
#set-default-sink alsa_output.platform-sound-simple-card.analog-stereo
#set-default-source input
set-default-source alsa_input.OnBoard_D1

Looks like it has been changed to set-default-source alsa_input.OnBoard_D1
Reply
#20
(04-06-2019, 05:10 AM)Jay Smith Wrote:
(04-05-2019, 02:55 PM)StormingMeccanoMan Wrote: It does not seem to help to use this method to control hdmi volume using the slider.  Any ideas?

Regards

You can look at this and remember to re-edit, if it causes you problems.
Note:  This maybe out dated.  I don't want to mess with my HDMI Volume Control as it has been working for some time.


The volume control depends on what PulseAudio default sink when it starts.
You can set default sink at /etc/pulse/default.pa:
set to HDMI
set-default-sink alsa_output.platform-sound-simple-card.analog-stereo
set to 3.5mm
set--default-sink alsa_output.hw_0_2
After setting, you MUST restart PulseAudio:
pulseaudio --kill
pulseaudio --start

Previously, mine was somehow set to 'set-default-sink alsa_output.platform-sound.analog-stereo'.



This is the last line in my etc/pulse/default.pa

### Make some devices default
#set-default-sink output
#set-default-sink alsa_output.platform-sound-simple-card.analog-stereo
#set-default-source input
set-default-source alsa_input.OnBoard_D1

Looks like it has been changed to   set-default-source alsa_input.OnBoard_D1

This is my default.pa from the same place,

### Make some devices default
#set-default-sink output
#set-default-sink alsa_output.platform-sound.analog-stereo
#set-default-sink alsa_output.platform-sound-simple-card.analog-stereo
#set-default-source input
set-default-source alsa_input.OnBoard_D1

I think I have tried all the defaults, but mine too has had the last line appear.

Thanks for your time on this,

Storming
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)