This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SSH login without local login
#1
Hi,

I've back from Armbian to TinkerOS and am looking for a solution.
Recently I installed the latest version of TinkerOS, 2.0.7.
And I found I can't ssh login prior to local login, i.e tty login.
It always require local login.
Please advice how I can fix this.

Thank you in advance.
/Junzo
Reply
#2
Just read this Wink . Which means you need to set up the ssh client to be a DHCP server, the TB will find the ethernet connection.

It should suffice. But feel free to ask more details.
Reply
#3
Im4Tinker, Thank you for your advice.
I found another approach. I did the following. It works.
1) Edit WiFi file under /etc/NetworkManager/system-connections/.
    In my case, the WiFi file is "aterm-04fd55".
    Find the line "permission=" and comment out the line.
I can ssh log in after reboot without local login,
NOTE: I'm not sure this modification will effect on security.
Reply
#4
Thank you for your information, I'll add it to my guidelines.
What I guess is the same as I used by setting dhcp server manually.
So after that modification how did you find the TB IP. Is NM showing the connection once you plugged the wire?
For my case I did manually, because I need to connect to the hotspot wireless. So for such event I can have both networks up. I suspect NM will give only one active connection, isn't it ?
Reply
#5
Hi Im4Tinker,
> how did you find the TB IP.
I have a dhcp server in a room and it will keep the same IP in the most cases.
I have to find the IP using ping command or other tools if the IP has been changed by some reasons.
Here is the result of nmcl command.  
linaro@tinkerboard:~/bluetooth$ nmcli connection show --active
NAME            UUID               TYPE             DEVICE
aterm-04fd55  *************  802-11-wireless  wlan0
Reply
#6
OK, to have a DHCP server will give the access to TB, as I presumed.
To find the assigned IP you might have by the query to the DHCP server to see the lease list.
Reply
#7
There's an update on that thread. Which modify the NM behavior. Then it will manage to start the ethernet connection once is plugged in.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)