This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Display issues at certain resolution
#1
I'm getting green lines on my display at its native 2560x1600. 1080p is clean. I just switched to trying Tinker Board, was using a Rock64 and it didn't have any issues going to this screen at native res. Whilst the Tinker Board saw the native res right away the Rock64 I did need to make a custom xrandr profile to make it output the correct res, but after that it was just fine. I tried adding that same profile setting in TinkerOS, but it wouldn't output to the screen at all when using it.

What are my options? Generally when I see this kind of issue it's a bad cable or connection in the video signal, but it works fine with the Rock64 so I was wondering if it was getting bad timings. But then again, the timings that worked on Rock64 also don't work here.
Reply
#2
(12-05-2018, 06:23 AM)damej Wrote: I'm getting green lines on my display at its native 2560x1600. 1080p is clean. I just switched to trying Tinker Board, was using a Rock64 and it didn't have any issues going to this screen at native res. Whilst the Tinker Board saw the native res right away the Rock64 I did need to make a custom xrandr profile to make it output the correct res, but after that it was just fine. I tried adding that same profile setting in TinkerOS, but it wouldn't output to the screen at all when using it.

What are my options? Generally when I see this kind of issue it's a bad cable or connection in the video signal, but it works fine with the Rock64 so I was wondering if it was getting bad timings. But then again, the timings that worked on Rock64 also don't work here.

Could you provide the settings of timing with 2560x1600?
Do you use the "xrandr" command to change the resolution?
[-] The following 1 user Likes ashinlin's post:
  • damej
Reply
#3
Code:
xrandr --newmode "2560x1600_60.00"  348.50  2560 2760 3032 3504  1600 1603 1609 1658 -hsync +vsync
xrandr --addmode HDMI-1 "2560x1600_60.00"

That gives me the new mode and then I just select it through the monitor settings. It works for me on Rock64, not on Tinker Board.
Reply
#4
I think will be more informative if you post
Code:
$ xrandr --verbose
from Tinker Board.
I suppose that another machine may work better with different setting and they'll be listed, rather than TBS, even for the same monitor/TVset.
Light blue words might be a link. Have you try to click on them? Big Grin
Reply
#5
Oops, thought that was asking the settings that had previously worked. Here's that output down to the part of native resolution.

Code:
Screen 0: minimum 320 x 200, current 2560 x 1600, maximum 8192 x 8192
HDMI-1 connected primary 2560x1600+0+0 (0x44) normal (normal left inverted right x axis y axis) 700mm x 390mm
       Identifier: 0x41
       Timestamp:  175726697
       Subpixel:   unknown
       Gamma:      1.0:1.0:1.0
       Brightness: 1.0
       Clones:
       CRTC:       0
       CRTCs:      0
       Transform:  1.000000 0.000000 0.000000
                   0.000000 1.000000 0.000000
                   0.000000 0.000000 1.000000
                  filter:
       EDID:
               00ffffffffffff0065e2003200000000
               181b0103804627782e6b35a455559f27
               0c5054230800d1c0810081c08180a9c0
               b30001010101d16f00a0a04030603020
               3600bc862100001e000000ff00303030
               30303030303030303030000000fd003b
               3f1e5f19000a202020202020000000fc
               0045333239310a202020202020200128
               020328f14f1005040302071601141f12
               13202122230907078301000067030c00
               1000383de3050301023a801871382d40
               582c250055502100001e011d8018711c
               1620582c250055502100009e011d0072
               51d01e206e28550055502100001e8c0a
               d08a20e02d10103e9600555021000018
               0000000000000000000000000000004d
       hue: 50
               range: (0, 100)
       saturation: 50
               range: (0, 100)
       contrast: 50
               range: (0, 100)
       brightness: 50
               range: (0, 100)
       hdmi_output_mode_capacity: 7
               range: (0, 15)
       hdmi_color_depth_capacity: 7
               range: (0, 255)
       hdmi_output_colorimetry: None
               supported: None, ITU_2020
       hdmi_output_format: output_rgb
               supported: output_rgb, output_ycbcr444, output_ycbcr422, output_ycbcr420, output_ycbcr_high_subsampling, output_ycbcr_low_subsampling, invalid_output
       hdmi_output_depth: 24bit
               supported: Automatic, 24bit, 30bit
 1920x1080 (0x43) 148.500MHz +HSync +VSync +preferred
       h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.50KHz
       v: height 1080 start 1082 end 1087 total 1125           clock  60.00Hz
 2560x1600 (0x44) 286.250MHz +HSync +VSync *current +preferred
       h: width  2560 start 2608 end 2640 total 2720 skew    0 clock 105.24KHz
       v: height 1600 start 1603 end 1609 total 1648           clock  63.86Hz
Reply
#6
(12-05-2018, 03:34 PM)damej Wrote:
Code:
xrandr --newmode "2560x1600_60.00"  348.50  2560 2760 3032 3504  1600 1603 1609 1658 -hsync +vsync
xrandr --addmode HDMI-1 "2560x1600_60.00"

That gives me the new mode and then I just select it through the monitor settings. It works for me on Rock64, not on Tinker Board.

In Tinker Board, we should not support the clock over 297MHz.
So, the settings that you provide is not workable. Your clock is 348.50.
Can I know where do you get this settings?


You can try this settings.
xrandr --newmode "2560x1600_60.00" 268.5 2560 2608 2640 2720 1600 1603 1609 1646 +hsync -vsync
Reply
#7
(12-06-2018, 09:27 AM)ashinlin Wrote: In Tinker Board, we should not support the clock over 297MHz.
So, the settings that you provide is not workable. Your clock is 348.50.
Can I know where do you get this settings?


You can try this settings.
xrandr --newmode "2560x1600_60.00" 268.5 2560 2608 2640 2720 1600 1603 1609 1646 +hsync -vsync

I got those settings by using the command 'cvt 2560 1600'

I've tried those settings you listed and I get no output to screen with them.
Reply
#8
(12-06-2018, 03:03 PM)damej Wrote:
(12-06-2018, 09:27 AM)ashinlin Wrote: In Tinker Board, we should not support the clock over 297MHz.
So, the settings that you provide is not workable. Your clock is 348.50.
Can I know where do you get this settings?


You can try this settings.
xrandr --newmode "2560x1600_60.00" 268.5 2560 2608 2640 2720 1600 1603 1609 1646 +hsync -vsync

I got those settings by using the command 'cvt 2560 1600'

I've tried those settings you listed and I get no output to screen with them.

Please help to provide the screen result of the command "xrandr -q"
It seems that you have already supported the 2560x1600 from your EDID info.
Reply
#9
Code:
Screen 0: minimum 320 x 200, current 2560 x 1600, maximum 8192 x 8192
HDMI-1 connected primary 2560x1600+0+0 (normal left inverted right x axis y axis) 700mm x 390mm
  1920x1080     60.00 +  60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98
  2560x1600     63.86*+
  1680x1050     59.88
  1600x900      60.00
  1280x1024     60.02
  1280x800      59.91
  1280x720      60.00    50.00    59.94
  1024x768      60.00
  800x600       60.32    56.25
  2560x1600_60.00  59.97

Yes, it 'supports' it. But I get green flickering lines across the screen. This does not happen when I use a different device plugged into the screen running at this resolution.
Reply
#10
(12-07-2018, 07:11 AM)damej Wrote:
Code:
Screen 0: minimum 320 x 200, current 2560 x 1600, maximum 8192 x 8192
HDMI-1 connected primary 2560x1600+0+0 (normal left inverted right x axis y axis) 700mm x 390mm
  1920x1080     60.00 +  60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98
  2560x1600     63.86*+
  1680x1050     59.88
  1600x900      60.00
  1280x1024     60.02
  1280x800      59.91
  1280x720      60.00    50.00    59.94
  1024x768      60.00
  800x600       60.32    56.25
  2560x1600_60.00  59.97

Yes, it 'supports' it. But I get green flickering lines across the screen. This does not happen when I use a different device plugged into the screen running at this resolution.
It seems that your monitor's clock is 286.250MHz, so you get the wired refresh rate 63.86.
Could you give a try for other clock rates? like 50 or 30.
You can just use command of "cvt" to get the related settings.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)