This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hostapd Channel not supported on supported channels
#1
I also posted this in the RPi troubleshooting forums, trying to get an answer (Just in case someone saw an identical post and thought that was weird).

I have been troubleshooting this one for a little while and I keep getting the same results.  Was hoping someone here might be more knowledgeable than me.

If I use Channels 8-12, I get the same error:
Code:
wlan0: IEEE 802.11 Configured channel (10) not found from the channel list of current mode (1) IEEE 802.11g
wlan0: IEEE 802.11 Hardware does not support configured channel
Starting advanced IEEE 802.11 management: hostapd failed!

And channels 1-7 work as intended.

My hostapd.conf is:
Code:
interface=wlan0
driver=nl80211
ssid=PocketVPN
hw_mode=g
ieee80211n=1
ht_capab=[SHORT-GI-40][HT40+][HT40-][DSSS_CCK-40]
channel=10
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=1234567890
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

However iw list shows:
Code:
sudo iw list
Frequencies:
    * 2412 MHz [1] (30.0 dBm)
    * 2417 MHz [2] (30.0 dBm)
    * 2422 MHz [3] (30.0 dBm)
    * 2427 MHz [4] (30.0 dBm)
    * 2432 MHz [5] (30.0 dBm)
    * 2437 MHz [6] (30.0 dBm)
    * 2442 MHz [7] (30.0 dBm)
    * 2447 MHz [8] (30.0 dBm)
    * 2452 MHz [9] (30.0 dBm)
    * 2457 MHz [10] (30.0 dBm)
    * 2462 MHz [11] (30.0 dBm)
    * 2467 MHz [12] (20.0 dBm) (no IR)
    * 2472 MHz [13] (20.0 dBm) (no IR)
    * 2484 MHz [14] (disabled)

I also tried forcing my region (US) using 
Code:
sudo iw reg set US

Code:
sudo iw reg get US
Which returns:

Code:
country US: DFS-FCC
        (2402 - 2472 @ 40), (N/A, 30), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57240 - 63720 @ 2160), (N/A, 40), (N/A)

I think I solved this, although I am not quite sure why.

This was being caused by:
Code:
ht_capab=[SHORT-GI-40][HT40+][HT40-][DSSS_CCK-40]

It seems the 40Mhz spectrum was not allowing me to use channels above 7. Once I removed this line, all started working again as intended.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)