This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setting system date time manually
#1
Any one tried to set the system date time manually from command line?

I tried the following command:

linaro@tinkerboard:~$ sudo date -s "2019/02/02 11:05:05"
Sat Feb  2 11:05:05 HKT 2019
linaro@tinkerboard:~$ date
Fri Jan  4 10:31:57 HKT 2019

After setting, it shows the original date and time and i try to read back

Please help me...

Thanks
Reply
#2
Try this.

$ sudo timedatectl set-ntp false

From: https://superuser.com/questions/983905/l...ot-working
Big Grin  I'm Lyle. 
Reply
#3
(01-04-2019, 09:06 AM)lsb Wrote: Try this.

$ sudo timedatectl set-ntp false

From: https://superuser.com/questions/983905/l...ot-working

Hi, thanks for your advice.
I have tried to run

$ sudo timedatectl set-ntp false 

follow up

$sudo date -s "2019/02/02 13:05:05

But the date on the bottom right does not  change. I tried to type 

$sudo date

it shows current time again.



Any further advice
?
Reply
#4
post
Code:
$ timedatectl
But it might be an issue with fake-hwclock.
Light blue words might be a link. Have you try to click on them? Big Grin
Reply
#5
Hi Im4Tinker,

I have tried using timedatectl. it is still not changing the system time.

I am sorry.. I tried again with "sudo". it works! Thanks Tinker
Reply
#6
Just for some courtesy, wouldn't it be good to put [Solved] ? Just edit your first post.
When researcher need same information, will have a reference with this discussion, that has worked Wink
Light blue words might be a link. Have you try to click on them? Big Grin
Reply
#7
Hi,

For LXDE's system tray (bottom right corner), it need times for the next synchronize time to update its information.

Anyway,
you need to disable NTP function first, then you have able to set datetime manually.
Code:
sudo timedatectl set-ntp false
Then set your times.
After that, you can check it via:
Code:
timedatectl
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)