This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TinkerOs Linux-headers?
#1
Hi,

I bought Tinker Board S on yesterday, so I'm pretty noob with this board.


I noticed that the TinkerOS  v.2.0.8 support very narrow scale to camera modules. I need driver to OV5640 so seems like that I must  do that for my self.


I just waste six hours to solve how I get installed the linux-headers to make kernel modules.
- There is no any dpkg (4.4.132) package for that, I tried to install from Tinker Git channel to linux-headers-4.4.132 deb package but that broke the Make tool. So tried to rebuild the kernel but no any hurrays for that.

- I tried also clone the kernel and make the sym link to /usr/src -folder with clean os image and then again rebuild the kernel - and still not work.

I was tried like all threads with google but there is no answer.
So people is there any easy way to get installed the linux headers or is it better to change operating system?

Thanks in advance
Reply
#2
Try another installation, perhaps Armbian. The Armbian staff are very active Tongue
Light blue words might be a link. Have you try to click on them? Big Grin
Reply
#3
Hi

You can find header files from our kernel source codes.
https://github.com/TinkerBoard/debian_kernel <-- remember checkout branch to your image release version.
[Image: RmK19dk.png]

Code:
cd ~
# download your image version's whole kernel source code
git clone https://github.com/TinkerBoard/debian_kernel.git -b 2.0.8 --depth 1

# Make a symbolic link to kernel source
ln -s ~/debian_kernel /usr/src/linux-headers-$(uname -r)

or find header files from releases deb.
https://github.com/TinkerBoard/debian_kernel/releases
currently have v2.0.7 & 2.0.8's.
Reply
#4
I changed in Armbian and thats working. Thanks.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)