This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
how to change runlevel in tinker os just by editing files in the SD memory
I am trying to find out what is going wrong with my tinker os .... it weird situation happening during boot process.... 

I am just looking for a way to lower the runlevel by editing the SD card files obviously because the SD card doesn't boot up successfully given my hardware ...

I studied below link which says there should be /etc/inittab files which apparently doesn't exist on the SD card (at least not for v2.0.7/8). 


There is also a statement in the link above which is :

"You may override the default runlevel with kernel parameter. When the boot menu is displayed, select the edit option. Then locate the kernel line and append space and the desired runlevel number. E.g. "kernel /boot/vmlinuz-2.6.30 root=/dev/sda2 ro 3" would boot to runlevel 3."

but honestly I have no clue what it means. In particular I don't understand what it means by "When the boot menu is displayed" at least I can't find the boot menu with tinker OS may by I am looking at a wrong place.

Any clue is much appreciate it.

To stop the process to the terminal login you may see this, which is just a modification to the /boot/extlinux/extlinux.conf at the append line.
To do that, you just plug the SD card or the TB to a linux box and edit that file Wink
This may apply for TinkerOS (aka linaro) and Elar System installation, which they use the extlinux booting method. For armbian is a different method.
Light blue words might be a link. Have you try to click on them? Big Grin
/boot/ is empty if try to change from another linux box... The thing is that the error I am getting happens before I get the login prompt and it keeps happening and won't the log in to even show up let alone editing stuff in /boot. 

Thanks anyway
One thing is that you need administrator privileges. Another it looks like the rootfs is not integer.
It easy to check just after completed the image writing. The linux box might be able to discover the new media, and a notification may appear. At that point it might be easy to open to read the content.

For tinkerOS, there will be 2 devices listed. One will be of 64 Megabytes and it's where the extlinux.conf resides.
After a image writing you should be able to see all the rootfs. But if you look into the bigger partition, the the /boot is empty, because it will mount the small partition there when the OS starts.

Sorry if I didn't clarified this point.
Light blue words might be a link. Have you try to click on them? Big Grin
[-] The following 1 user Likes Im4Tinker's post:
  • mikeitexpert
No problem ... thank you for valuable details .... below please find the content of extlinux.conf from the 64mb partition...

But I just can't find any value for runlevel ... am I missing it or there is sth I can change/add ?

Please let me know otherwise I have to look into buying a new monitor :|

thank you,

label kernel-4.4
    kernel /zImage
    fdt /rk3288-miniarm.dtb
    append  earlyprintk quiet splash plymouth.ignore-serial-consoles console=tty1 rw init=/sbin/init

I just added 3 after rw .... and then booted the board it seems working so far... fingers crossed Smile
Thanks Bro it was really helpful and worked as I expected MUCH MUCH appreciate you comment.
(01-16-2019, 04:27 AM)mikeitexpert Wrote: ... otherwise I have to look into buying a new monitor :|
We're keen to help you to solve your monitor problem, in a new thread Wink

BTW, it's nice to see [Solved] to the thread title, it helps others to find a solution. Just edit the first post title.
Light blue words might be a link. Have you try to click on them? Big Grin

Forum Jump:

Users browsing this thread: 1 Guest(s)