This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
x11vnc autostart on tinkerOS
#1
I installed x11vnc on my tinkerOS. I set the autostart by adding "@x11vnc -forever -usepw" to the last line of ~/.config/lxsession/LXDE/autostart file (going through the GUI doing manually). But, now when i connect to it, i get a new desktop and not the active one. The primary desktop is seen idle on the hdmi output of the board and there is another desktop running in vnc. I tried adding command -display :0, but it isn't working. Everytime it gets connected to tinkerboard:1 while I believe my primary desktop is tinkerboard:0. This problem doesn't occur when i am starting the x11vnc manually and not with the autostart.
I need to sort this quickly in order to complete my project. Thanks in advance!
Reply
#2
No VNC can connect to the display:0 by default.
This might be of some help. Even better to read the entire document.
Light blue words might be a link. Have you try to click on them? Big Grin
Reply
#3
Thank you, the problem was in the commands i was using. It got sorted. 

Also, I got a new problem, I installed android on the board. But that android can't access the connected pi camera. Is there a way to make it recognise the camera? I am using the pi 5mp v1 camera.
Thanks again.
Reply
#4
Sorry, this thread is [Solved]. For better results and focus open a relevant discussion. I don't think exists an user's problems thread Big Grin
For your camera it's preferred to see some more details and what logs may say about.
Light blue words might be a link. Have you try to click on them? Big Grin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)