This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't get xinit to startup up
I am using Debian 2.08 and I am trying to get xinit to start chromium in kiosk mode and I keep hitting 

[    12.071] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices

this is what I have in 20-modesetting.conf

The LCD is supposed to be 1024x600, but it flickers horribly and on initial desktop this resolution worked fine -- after I switched to xinit from console 
I can't get it to startup.

With armbian xinit boots, but I can't set resolution -- it defaults to 1920x1080 -- which doesn't work on this screen. 

linaro@tinkerboard:/etc/X11/xorg.conf.d$ cat 20-modesetting.conf
Section "Device"
    Identifier  "Rockchip Graphics"
    Driver      "modesetting"
    Option      "AccelMethod"    "glamor"
    Option      "DRI"            "2"
Section "Monitor"
    Identifier "Monitor 0"
    Modeline "1152x648_60.00"   59.25  1152 1200 1312 1472  648 651 656 674 -hsync +vsync
Section "Screen"
    Identifier "Default Screen"
    Monitor "Monitor 0"
    SubSection "Display"
        Depth 24
        Modes "1152x648"
You might check the discovered modelines by
xrandr --verbose
then check on the bottom.
Light blue words might be a link. Have you try to click on them? Big Grin

Forum Jump:

Users browsing this thread: 1 Guest(s)