This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fsck at boot on the emmc
Hello people,
I am trying to make my Tinker Board to fsck at boot, and while I have errors on the filesystem even more so,
have tried, changing FSCKFIX=no to yes in /etc/default/rcS, doing touch /forcefsck, tunefs -c1 /dev/mmcblk1p2, and even adding fsck.mode=force to the kernel parameters with countless reboots in between tests but fsck.ext4 -nf /dev/mmcblk1p2 still reports errors on the filesystem, and while these tricks did work on an other SBC it will not on the TB and I am out of ideas if anyone can help.
Try a systemd service Wink like systemd-fsck@/dev/mmcblk1p2.service.
Or even check what fsck are performed during boot time
$ sudo journalctl -b |grep fsck
Anyway I wonder why this obsession to get the eMMC checked so often. There should be settings where you might decide the frequency to check the file system.
Light blue words might be a link. Have you try to click on them? Big Grin
seems that service systemd-fsck-root is failing with 'ConditionPathIsReadWrite=!/ was not met', tried setting errors=remount-ro option that was missing on fstab and on the partition with tune2fs, and even turned the partition dirty with debugfs manually as tune2fs was saying it was clean, anyways I got bored trying to fsck at boot and connected with the OTG to another linux where I fsck.ext4 -y /dev/sdb2 at the time, when I brought it back online and run fsck with -nf again it reported the same errors on mmcblk1p2 which it does confuse me at this point
Well, I've few ideas.
Maybe try a different OS, or try with badblocks, but it might be early to worry about damaged cells.
Light blue words might be a link. Have you try to click on them? Big Grin

Forum Jump:

Users browsing this thread: 1 Guest(s)