This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nougat, adb shell+dmesg and future issues?
--EDIT 30 Jan 2019: the attachment didn't go up yesterday for some reason, now added--

Admittedly, I am not proficient with android/linux, but this is crazy.

I decided that I would dust of the tinker board (not touched in nearly a year) and would use it as a second car pc.  (My goal is that the TB would run android and the following apps: Life360, Waze, Craftsman Garage Door Opener.  The "primary" computer is currently a mini-ITX running Win10 which is primarily used for TunerPro and DriveLine.  The mini-ITX is being replaced with a LattePanda Alpha....yes, I could run bluestacks on the LPA/Windows, but the TB begs to be used.)

Android Hardware: TB, GlobalSat BU-353 GPS antenna, 8" LCD monitor with Egalax resistive touch overlay (USB).

So the issue?  I downloaded the Nougat ( image and wrote the image to an SD card.  I then installed Google Play Store from which I installed Life360, Waze, the Garage door app, and just a couple of ancillary utilities (e.g., terminal).  All was well until I tried to get the GPS drivers installed.

I planned to follow instructions in the libGPS thread.  Unfortunately, I get as far as running dmesg in the adb shell.  Instead of getting pertinent information (i.e., the device identifier similar to ttyACM0), i get hundreds of lines of errors.  (Image attached.)  Thinking that this was due in some unexplicable way to the ethernet connection (not likely), I ran dmesg on the TB.  Same result--nothing but hundreds of "undelivered transaction xxxxxx, process died" errors.

Other commands (e.g., dmesg | grep | -i usb) are not recognized in android, and lsusb list just the device # and hex ID.

Any thoughts?  Is this somehow a Nougat build issue?  Am I embarking on a path doomed to failure (given my limited proficiency)?

thanks in advance

Attached Files Thumbnail(s)

kimnach dot org

Forum Jump:

Users browsing this thread: 1 Guest(s)