This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error creation point wifi access
#1
Is it possible to make our thinkerboard a wifi hotspot using the lan network?.I have an Armbian operating system on a S thinkerboard
and i have done the installation following these steps and I create the connection but I can not connect any device.
Can there be some kind of problem with the wifi device?

Code:
sudo apt-get update

sudo apt-get upgrade

sudo apt-get install hostapd isc-dhcp-server

sudo apt-get install iptables-persistent

sudo nano /etc/dhcp/dhcpd.conf

#option domain-name "example.org";
#option domain-name-servers ns1.example.org, ns2.example.org;

# If this DHCP server is the official DHCP server for the local
# network, the authoritative directive should be uncommented.
authoritative;

subnet 192.168.42.0 netmask 255.255.255.0 {
range 192.168.42.10 192.168.42.50;
option broadcast-address 192.168.42.255;
option routers 192.168.42.1;
default-lease-time 600;
max-lease-time 7200;
option domain-name "local";
option domain-name-servers 8.8.8.8, 8.8.4.4;
}

sudo nano /etc/default/isc-dhcp-server

INTERFACES="wlan0"

sudo ifdown wlan0

sudo nano /etc/network/interfaces

allow-hotplug wlan0
iface wlan0 inet static
 address 192.168.42.1
 netmask 255.255.255.0

sudo ifconfig wlan0 192.168.42.1

sudo nano /etc/hostapd/hostapd.conf

interface=wlan0
#driver=rtl871xdrv
ssid=WIFI_NAME
country_code=ES
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=PASSWORD
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP
wpa_group_rekey=86400
ieee80211n=1
wme_enabled=1

sudo nano /etc/default/hostapd

DAEMON_CONF="/etc/hostapd/hostapd.conf"

sudo nano /etc/init.d/hostapd

DAEMON_CONF=/etc/hostapd/hostapd.conf

sudo nano /etc/sysctl.conf

net.ipv4.ip_forward=1

sudo sh -c "echo 1 > /proc/sys/net/ipv4/ip_forward"
sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
sudo iptables -A FORWARD -i eth0 -o wlan0 -m state --state RELATED,ESTABLISHED -j ACCEPT
sudo iptables -A FORWARD -i wlan0 -o eth0 -j ACCEPT

sudo sh -c "iptables-save > /etc/iptables/rules.v4"
Reply
#2
Try this.
Eventually you might try to set it up and then copy the dnsmasq configuration which it generates in /tmp.
Light blue words might be a link. Have you try to click on them? Big Grin
Reply
#3
What about this way?

https://www.youtube.com/watch?v=__BJtInOQFY
Armbian. Lightweight Debian Stretch or Ubuntu Bionic for Tinker Board.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)