This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GPIO UART1 - ttyS1 Communication
#1
Exclamation 
Dear tinkerboard community!

I am currently evaluating this product for use as an IoT gateway.

When looking at the GPIO Uart, communication, setup etc. It seems this isn't very well documented, as it is on the raspberry pi.

I'm trying to setup an equivialent setup as I've had on the raspberry pi with this addon card "HAT".

Sixfab IoT HAT (modem) 4G

The Sensors are working with some modifications, but the communication with the modem, I cant get to work properly.


I've read that there are some small changes needed to enable the serial port on the tinkerboard, but I've tried everything now, and are alittle lost.

Anyone out there, who have an answer for this?

With best regards,
David
Reply
#2
You should see the pinout
[Image: Gpio-pinout.png]
And look into /boot/hw_intf.conf in order to enable the UART expected to use. Note that pwm has the higher priority, so it must be disabled, then the UART become available.
Light blue words might be a link. Have you try to click on them? Big Grin
Reply
#3
Information 
Thank you for replying.

My file looks like this:



#Hardware Interface Config

intfConfusedpi0=on
intf:uart2=on
intf:uart3=on
intf:uart4=on
intf:pcm_i2s=on
intf:i2c1=on
intf:i2c4=on
intfConfusedpi2=on
intf:pwm2=on
intf:pwm3=on
intf:uart1=on

#DTS Overlay Config
# 1. check the name.dtbo in /boot/overlays
# 2. add intf:dtoverlay=name as below

#intf:dtoverlay=i2c


So according to what your are saying, I have to disable the pwm and all other uarts than uart1, which is the one I have to use. ??

Do I have to make any modifications inside the /boot/extlunux file ?



label kernel-4.4

    kernel /zImage

    fdt /rk3288-miniarm.dtb
    append earlyprintk quiet console=ttyS3,115200n8 rw init=/sbin/init



Best regards,
David
Reply
#4
Hello again, It sure looks like the UART1 is enabled for debugging.

As fas as I understand at this point, the only way for making use of the UART1, I'll have to change the debug to another uart in the u-boot and recompile a new image and flash this to the TB.

Correct??

NB: I have to use the Uart1, this is kinda needed because of the adapterCard which im using.
pins, 8 and 10.

If so, anyone have any tutorials for this procedure?

Regards,

David
Reply
#5
Quote: have to disable the pwm and all other uarts than uart1
Not exactly, I'd correct the statement that the PWM channel has the priority over its UART, which sharing the same pins. No problems if you'll leave the other UARTs on their settings.

If you trying the  debugging during boot time, better you leave the things as they are. You just need to plug the adapter on the UART 3 and, eventually, modify extlinux.conf to remove the Plymouth and quiet from the append line.
Code:
label kernel-4.4
   kernel /zImage
   fdt /rk3288-miniarm.dtb
   append  earlyprintk console=ttyS3,115200n8 console=tty1 rw init=/sbin/init
This works for me
I don't see the necessity to change things up. Even I agree that the tinkerOS (aka linaro) doesn't use a standard mode. Because the standard is on tty2.
If you're using Armbian then the music is rather different, they system goes in the standard so we just plug on UART2.

For a simple test, you might try to address the UART1 by minicom, picocom or other simple terminal and test if the loopback by shorting the RX and TX will send you the characters back to you.
See


If you have a positive result then it won't be difficult to use UART1
Light blue words might be a link. Have you try to click on them? Big Grin
Reply
#6
Hi David,

If you are trying to use this shield (Sixfab Raspberry Pi 3G-4G/LTE Base Shield V2).
I've made it work via ttyS1 and ttyUSB3.
[-] The following 1 user Likes alansv's post:
  • Awia
Reply
#7
Hi,

i´m on the same Mission with the Sixfab/EC25 on Android.
but currently i´m stuck due not availlable of ttyUSB*

i get errors on:

Code:
04-13 05:52:10.088   525  1354 D gps_ql  : fail to open GPS channel </dev/ttyUSB3>!
04-13 05:52:11.125   525  1354 D gps_ql  : GPS channel </dev/ttyUSB3> not exist. errno: 2 (No such file or directory)
04-13 05:52:11.125   525  1354 D gps_ql  : fail to open GPS channel </dev/ttyUSB3>!
04-13 05:52:12.130   525  1354 D gps_ql  : GPS channel </dev/ttyUSB3> not exist.errno: 2 (No such file or directory)
04-13 05:52:12.130   525  1354 D gps_ql  : fail to open GPS channel </dev/ttyUSB3>!

and if i check /dev/ there is no ttyUSB*

how and where can i enable it and what you guys talk about disable PWM? is that Linux OS related ?

rgds,

n0tiert
Reply
#8
Hello n0tiert,

have you looked in adb shell with dmesg what happens, if you connect the usb cable?
You can post the result also here.
Further you can take a look here, if you need to modify the permission of the serial interface:
https://tinkerboarding.co.uk/forum/threa...ml#pid2585
Reply
#9
Hi Lobo

i´m getting closer to the goal Smile

Code:
[  243.383194] usb 1-1.4: new high-speed USB device number 6 using dwc2
[  243.473618] usb 1-1.4: New USB device found, idVendor=2c7c, idProduct=0125
[  243.473838] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber                                                                                                                               =0
[  243.473950] usb 1-1.4: Product: Android
[  243.474045] usb 1-1.4: Manufacturer: Android
[  243.487617] qmi_wwan 1-1.4:1.0: Quectel EC25&EC21&EG91&EG95&EG06&EP06&EM06&BG                                                                                                                               96&AG35 work on RawIP mode
[  243.489992] option 1-1.4:1.0: GSM modem (1-port) converter detected
[  243.495925] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB0
[  243.497900] option 1-1.4:1.1: GSM modem (1-port) converter detected
[  243.498679] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB1
[  243.499537] option 1-1.4:1.2: GSM modem (1-port) converter detected
[  243.500301] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB2
[  243.501126] option 1-1.4:1.3: GSM modem (1-port) converter detected
[  243.501837] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB3
[  243.503216] qmi_wwan 1-1.4:1.4: cdc-wdm0: USB WDM device
[  243.503243] qmi_wwan 1-1.4:1.4: Quectel EC25&EC21&EG91&EG95&EG06&EP06&EM06&BG                                                                                                                               96&AG35 work on RawIP mode
[  243.504373] qmi_wwan 1-1.4:1.4 wwan0: register 'qmi_wwan' at usb-ff540000.usb                                                                                                                               -1.4, WWAN/QMI device, xx:xx:xx:xx:xx:xx


but i still need to get the Uart running on 8/10 to get the gps going.

i´m playing with the u-boot & kernel>dts files atm
after changing UART_CH3 to 1 

an open question is how the parameter.txt is generated and where it takes FIQ0 from

rgds,

n0tiert
Reply
#10
Hi Sorry to interrupt. Because i need many inputs, I tried to configure Pin 8 and Pin 10 as GPIO.In in my program and edit hw_intf.conf (intf:uart1=off).
But when i read the input it is toggling '1' and '0'.

May I know if there is any things else that I should do?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)