This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NFS client crashes and docker woes
#1
I'm running a 3 node RPI docker swarm without problem. My persistent volumes are stored on my NAS and this has been working with for example Influxdb for several months.

Now I bought an Asus Tinker Board because of the 2GB RAM, so my influx instance can run on that one.. but I always have problems:

With TinkerOS, docker swarm is not working because of missing network modules
I installed armbian, which made docker able to join swarm and everything seems to work. I start up Influx service but after a while I start getting NFS cannot connect. After a while I also get a kernel panic about influxdb being unresponsive.

I've tried feeding through GPIO port and also bought the official power supply, also have a fan at the CPU.

So my question:
Is there some strangeness going on with the LAN driver in armbian for tinker board? Specifically regarding NFS4/tcp
Is it possible to get docker swarm running on TinkerOS ?
Is there some other OS for the tinker board that can run docker swarm?
Reply
#2
So I "solved" this myself. Apparently hardware offloading of tx-checksumming makes something crash. So for the moment I will just be disabling this.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)