This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High LAN Ethernet latency
#1
Hello everybody, what's the average Ethernet network latency you get from/to the Tinker Board ('S' model, if that matters) on your LAN? I'm getting something around 1 ~ 1.7 ms, which I find pretty high -- I'd expect something around 0.2 or 0.3 ms (that's what I get between 'regular' PCs on my network). Searching on Google I could find Raspberry Pi 3 B/B+ users reporting something around that, but nothing about the Tinker Board (hence the question here).

My home LAN is all CAT6 cabled with a basic D-Link Gigabit Ethernet switch. The network throughput is good, getting 900 MB+ to/from the TB, it's the latency that intrigues me, and since I'm running some things that are sensitive to latency, I'd like to reduce it.

I'm using the latest Armbian build, but got the same results with the default Linaro build.
Reply
#2
(06-24-2019, 06:13 PM)dbolivar Wrote: Hello everybody, what's the average Ethernet network latency you get from/to the Tinker Board ('S' model, if that matters) on your LAN? I'm getting something around 1 ~ 1.7 ms, which I find pretty high -- I'd expect something around 0.2 or 0.3 ms (that's what I get between 'regular' PCs on my network). Searching on Google I could find Raspberry Pi 3 B/B+ users reporting something around that, but nothing about the Tinker Board (hence the question here).

My home LAN is all CAT6 cabled with a basic D-Link Gigabit Ethernet switch. The network throughput is good, getting 900 MB+ to/from the TB, it's the latency that intrigues me, and since I'm running some things that are sensitive to latency, I'd like to reduce it.

I'm using the latest Armbian build, but got the same results with the default Linaro build.

Pi3 uses its USB2.0 bus for its network so I'd take what they say with a grain of salt.  That said I also have Odroid on the same physical network segment and I'm getting 0.55ms on TB and 0.25ms on Od so maybe your onto something.  We should be on the mainline kernel(which is why im here) so maybe with the new hardware support this will change...?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)