This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Change monitor resolution on startup TinkerOS1.8
#1
Hi,

Using TinkerOS1.8 beta the system only gives me a resolution of 800x600 instead of my monitors resolution of 1920x1200 (DVI-D monitor with HDMI to DVI-D adapter).

I've written and run a shell script from the command line to change the resolution to 1920x1200 but I've not had any luck getting the shell script to autoboot.


Code:
#!/bin/sh
xrandr --newmode "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
xrandr --addmode HDMI-1 1920x1200_60.00
xrandr --output HDMI-1 --mode 1920x1200_60.00

Any suggestions on how to permanently change the resolution?.

Regards

Nick
Reply
#2
Try adding adding

video=HDMI-A-1:1920x1200@60

to the append line in the /boot/extlinux/extlinux.conf

Regards
Brian
Reply
#3
(04-23-2017, 10:26 AM)euler Wrote: Using TinkerOS1.8 beta the system only gives me a resolution of 800x600.
Something is still wrong in kernel. The problem exists from TinkerOS 1.6.
I left this community in Aug 2017 due to ASUS bad product quality and ASUS community support that did not match my expectation.  Sad
Reply
#4
(04-23-2017, 12:57 PM)brianw Wrote: Try adding adding

video=HDMI-A-1:1920x1200@60

to the append line in the /boot/extlinux/extlinux.conf

Regards
Brian

Hi Brian,

Many thanks but it didn't change the resolution. The system is now crashing a few minutes after rebooting but it has been a bit flaky since I started using TinkerOS1.8  beta.

I will read up on extlinux.conf.

Regards

Nick
Reply
#5
(04-23-2017, 10:26 AM)Эйлер Wrote: Привет,

Использование TinkerOS1.8 бета система только дает мне разрешение 800х600 вместо моего разрешения мониторов 1920x1200 (DVI-D монитор с HDMI на DVI-D адаптер).

Я написал и запустить скрипт из командной строки , чтобы изменить разрешение на 1920х1200 , но у меня не было никакой удачи , получая сценарий оболочки для автоматической загрузки . Любые предложения о том , чтобы навсегда изменить разрешение ?. Привет Ник


Code:
#!/bin/sh
xrandr --newmode "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
xrandr --addmode HDMI-1 1920x1200_60.00
xrandr --output HDMI-1 --mode 1920x1200_60.00
https://www.youtube.com/watch?v=jkOfPZIIq-A      инснрукция на русском . но я думаю без труда можно повторить используя ваши настройки .сохранить настройки в конце видео
Reply
#6
I have a similar problem with an older SONY BRAVIA. The ASUS Tinkerboard with TinkerOS V1.3 as well as my Raspberry Pi 2 Model B with any version of Raspbian Jessie set the resolution to 1360x768@60Hz.

However, with TinkerOS V1.4 and above this no longer works. The resolution is such wrong that I even can't login. All I see is a long trash icon in the upper left corner. In one version (I tried all available versions from 1.4 to 1.8) I can see a small part of the login prompt, but as I'm working in the blind I can't do much either.

Of course I can login using PuTTy with ssh at anytime. Any idea about how to solve this problem is welcome!
Reply
#7
(05-01-2017, 08:07 PM)petergloor Wrote: I have a similar problem with an older SONY BRAVIA. The ASUS Tinkerboard with TinkerOS V1.3 as well as my Raspberry Pi 2 Model B with any version of Raspbian Jessie set the resolution to 1360x768@60Hz.

However, with TinkerOS V1.4 and above this no longer works. The resolution is such wrong that I even can't login. All I see is a long trash icon in the upper left corner. In one version (I tried all available versions from 1.4 to 1.8) I can see a small part of the login prompt, but as I'm working in the blind I can't do much either.

Of course I can login using PuTTy with ssh at anytime. Any idea about how to solve this problem is welcome!
I think I have a solution - it works for me so far.
On the command line type cvt 1920 1200 or cvt whatever the resolution you want.
This should give you the modeline values to put into:
/etc/X11/xorg.conf.d/20-modesetting.conf

Then add

Section "Monitor" Identifier "HDMI-1" Modeline "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync Option "PreferredMode" "1920x1200_60.00" EndSection

Section "Screen" Identifier "Screen0" Monitor "HDMI-1" DefaultDepth 24 SubSection "Display" Modes "1920x1200_60.00" EndSubSection EndSection


or the equivalent for your monitor at the end of the 20-modesetting.conf file.

Then select monitor settings (I used a GUI and I don't know how to do this from the command line) (might need to reboot ist) and select the new monitor. Then save this setting. Reboot to test.

Regards

Nick
Reply
#8
Hi there,

did you successful to change resolution to suit your monitor ?
Arrow  Everything is just at beginning
Reply
#9
(05-03-2017, 09:51 AM)euler Wrote: On the command line type cvt 1920 1200 or cvt whatever the resolution you want.
This should give you the modeline values to put into:
/etc/X11/xorg.conf.d/20-modesetting.conf

Then add

Section "Monitor" Identifier "HDMI-1" Modeline "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync Option "PreferredMode" "1920x1200_60.00" EndSection

Section "Screen" Identifier "Screen0" Monitor "HDMI-1" DefaultDepth 24 SubSection "Display" Modes "1920x1200_60.00" EndSubSection EndSection


or the equivalent for your monitor at the end of the 20-modesetting.conf file.

Then select monitor settings (I used a GUI and I don't know how to do this from the command line) (might need to reboot ist) and select the new monitor. Then save this setting. Reboot to test.

Regards

Nick

Absolutely clear and works fine.
Thanks
Reply
#10
(04-11-2018, 06:30 PM)FightingForFun Wrote: Good evening.

I have a problem and I do not know how to solve it. Help is needed.

I connected the tinkerboard to the TV, set screen resolution is 1360x768 @ 60. When the TV is turned off and then turned on, the 1920x1080 resolution automatically becomes.
How can I make it so that when the TV start/wake-up the resolution there was 1360x768?

And sometimes it happens that the screen for 1 second turns black, then again everything shows ... what can it be?

I can't use 1920x1080, because the TV does not display the desktop. Pixels of ~ 50 on each side crop.

Did you try to find some setting from the TV? 
E.g. Overscan, Underscan. or Display Pixels setting.
Maybe it can solve your TV cut pixels issue.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)