This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No signal /hdmi problem with android, 7" touch screen
#1
Sad 
UPDATE: In the end, I couldn't figure this out, due to the tinker not having a config.txt like the RPi does, I decided to get a Waveshare 7" from amazon which worked right away (and android was able to detect the resolution it was running). My guess here is that it is supposed to do some kind of handshake, which for some reason in Marshmallow this isn't a problem, but in Nougat this is. This old screen will work fine for another project I want to start. Sorry if anyone finds themselves here, but save the time and buy a LCD that is confirmed to work.

Posted this on the Android forum originally, someone suggested I try here.

Trying to get a 7" touch screen to work with my tinker (it looks like a waveshare imitation, didn't realize this was going to be a problem until after I ordered it, its 800X480). Im not really sure why, but with android version 6 (the .img with the play store already installed available on these forums) seemed to work ok when android boots. But the system itself had a lot of bugs, so for this reason I am trying to get version 7 to run. I should mention most of these bugs in version 6 seem to relate to the screen, and fiddling with the build.prop file and the screen settings helps somewhat, but i need this to be really stable, so currently its too buggy for its intended use. There is also a lot of added features in the version 7 kernel that I need.

So after updating to the latest image offered on here, (and all other nougat images available for this board) I'm struggling to get the display to work, its a black screen after the boot logo. It just says no signal. While connecting it to another display works fine, this is my main computer display that supports 1080p natively. I've tried setting the resolution in the android control panel to other resolutions (its set to auto, an option not available in Marsh mellow) no change.


I can connect to it via adb. Originally using adb i couldn't change the resolution, though i realize this was a problem on my end. All the same, this does nothing. I've read somewhere about how this monitor may not be able to communicate properly, not sure if this is the case. But the no signal problem seems like it isn't even receiving the system resolution messages, like its not even connected, rather than being out of sync.

Any idea what was different between version 6 and 7? Any idea if there is something I need to change in the build.prop? I have already tried changing the resolution and density, in build.prop, and using the android control panel and another screen, this does not seem to make a difference, wm size still says its 1080p (which also happened in version 6 but still seemed to work). Sort of out of idea outside of ordering a new screen, was hoping to avoid that.

Thanks for any help on the issue.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)