This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu 18.10 hotspot not working
#1
Please forgive me as I am a novice Linux user and new to this forum.

Hi all - I have the original TB and have installed Ubuntu 18.10. I plan to use it for Astronomy photography using Kstars and attached to my telescope. Consequently I need to connect to it remotely, and generally out if in the field where there is no network service ie it needs to run standalone.

I can get the TB to work via a network cable and via WiFi to my home network, and I can remote from my Windows 10 laptop using RDP (via wifi), but I can't get the TB to work in hotspot mode. Also I can wire both the TB and my laptop to a surplus modem/router and remote in that way - this is my plan-B for the moment. When I enable hotspot I get a blank screen, no options and no settings, and I am lost as to what to do next.

Can you provide some advice/tests/changes I can carry out to resolve my problem please.

Alex.
Reply
#2
(09-26-2019, 12:01 AM)Hava Wrote: ...When I enable hotspot I get a blank screen, no options and no settings, and I am lost as to what to do next...

Alex.

hi Hava,
I'm not sure if its the same for 18.10.. 
but for 18.04.. 
After creating a hotspot for the first time, 
a file called Hotspot is created in /etc/NetworkManager/system-connections, 
which holds some settings.

see if you can open a terminal and run..
Code:
sudo nano /etc/NetworkManager/system-connections/Hotspot

In this file you can configure the network SSID (it appears as ssid= under [wifi]), 
password (the Wi-Fi password is the value of psk= under [wifi-security]), 
and other settings.

After making changes to the Hotspot file, save it 
(to save the file in Nano command line text editor, press Ctrl + O, then Enter, and then exit using Ctrl + X).

After making changes to the hotspot configuration file you'll need to restart Network Manager:
Code:
sudo systemctl restart NetworkManager

Turn on Wi-Fi hotspot using command line on Ubuntu 18.04
Code:
sudo nmcli connection up <SSID>

hope it helps
----------------
k,
----
ps.. i got this info from here...
https://www.linuxuprising.com/2018/09/ho...buntu.html
Reply
#3
Thanks k - I will try a few things out this evening after work.

Alex.
Reply
#4
Or perhaps this (proven) way:

https://www.youtube.com/watch?v=__BJtInOQFY
Armbian. Lightweight Debian Stretch or Ubuntu Bionic for Tinker Board.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)