This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TinkerOS_Debian V2.0.11 NetworkManager manual speed setting does not work
#1
Watch out folks, changing the network interface speed/duplex setting from *automatic* to *manual* on the Tinkerboard may mess up your wired LAN connection in unexpected ways.


Long story:

Currently using TinkerOS_Debian V2.0.11 on the original Asus Tinkerboard and testing wired ethernet (private LAN) between the Tinkerboard and a Ubuntu machine (both with a fixed IP address, no dhcp, no router). 

If I edit the network settings of the wired connection (eth0) in the NetworkManager GUI of the Tinkerboard it appears that changing the speed/duplex setting from *automatic* to *manual* (1GB speed, full duplex) and rebooting has the effect of loosing the ability to connect to the LAN network. Despite NetworkManager of the Tinkerboard indicating an active connection (it will even display the connection information in the GUI), pinging the other host fails. If I change back to *automatic*, everything works as expected (i.e. fully functional connection at 1GB speed and full duplex). Furthermore, connecting both hosts either directly with an ethernet cable or connecting them via a 1GB switch makes no difference, i.e. everything works as expected in *automatic* mode but not in *manual* mode (on the Tinkerboard).

In contrast, changing the same NetworkManager setting on the Ubuntu machine (which also has a 1GB NIC) does not have the same effect, the LAN network connection works fine both in the *automatic* and the *manual* mode.

I do not know if this is a Tinkerboard driver issue or lack of hardware support by the Tinkerboard on-board NIC, but I don't care enough to dig any deeper. As mentioned, everything seems fine when using the *automatic* setting (haven't tried "ignore" though), but I thought it might be helpful to post it here as a heads up.
Reply
#2
Like a private LAN with static IP addresses, the behavior is the same for a zeroconf LAN with autoconfigured link-local IP addresses. I tested that after installing the required packages to get avahi-daemon and mDNS to work (unlike other distros, TinkerOs does not include those in the default image file). The result is the same when switching from *automatic* to *manual* speed/duplex mode in NetworkManager GUI on the Tinkerboard: now it's not possible anymore to connect to other hosts on the LAN (ping fails) despite the connection information as per NetworkManager claiming there being an active connection. When I switch back to *automatic* mode everything works as expected.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)