This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
xfce4 doesn't seem to work
#1
Can anyone get xfce to work perfectly on Tinker OS? I have tried xfce once on Armbian and I don't want to go back to lxde on Debian (Tinker OS).

I have tried to change the window manager of tinker os to xfce and didn't find much result from it. I have studied another post thread (xfce4 on Tinker Os by qaplus) and from other forums (but with other os's). I can't seem to make it work normally. Here are my findings that require compromises to work:

0. Prerequisites
-how to get it work in general
Code:
sudo apt install xfce4
sudo update-alternatives --config x-session-manager
and then select Xfce-session from the list


For Tinker OS, it will likely work without showing the desktop, everything works but you can't use wallpaper or add any desktop shortcuts. This leaves you a gray background of nothing.

1. Methods I have tried:

a. Using Openbox session to turn on xfce4
method:"startxfce4 &" in the autostart script located in ~/.config/openbox
results: the desktop environment is workable but the window manager is from openbox, which means you can't snap windows.

b. Changing desktop.conf in lxde
method:in  ~/.config/lxsession/desktop.conf --> change windows manager to xfwm4, start with lxsession
results: the windows manager is from xfce, but the panels are still lxde, snapping works but it does not look good and looks "crash-y"

c. [DANGEROUS] Please do not do this
Code:
apt-get purge --remove xserver-common

sudo apt-get install xserver-common xserver-xorg-core xserver-xorg-input-libinput xserver-xorg-input-evdev xserver-xorg-input-synaptics
This allows xfce to run natively, but the GPU acceleration is gone in chromium and likely everything else. I am not that fluent in linux but I believe this might have to do with the GPU driver.

Lastly, do you guys have any recommendation of desktop environment that would work on the tinker board?
I can confirm mate works, but I don't think it is as simple as xfce in terms of the settings and design.
Reply
#2
> Can anyone get xfce to work perfectly on Tinker OS?

https://www.armbian.com/tinkerboard/
1st download option is the only one where acceleration works with
https://forum.armbian.com/topic/7262-rk3...nkerboard/

or other variants with modern kernel.
https://www.armbian.com/tinkerboard/#ker...rchive-all

or a lot of work.

> but the GPU acceleration is gone in chromium
> I am not that fluent in linux

This is hard for experienced hackers.
Armbian. Lightweight Debian Stretch or Ubuntu Bionic for Tinker Board.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)