This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues with Bluetooth Gamepads Controllers
I’m having issues with my my bluetooth controllers/gamepads:
•XBox One Controller - Model 1708 - Bluetooth
•Emtec Bluetooth GEMPad for GEMBox - Android
•I’m running TinkerOS_Android v14.4.0.5 (the latest?)

Both controllers are not detected by Asphalt 9 Legends (yes, it run OKish) and Modern Combat 5. I also tried other games from the Playstore, but those 2 are the ones I’m mostly concerned. Basically nothings happens if I press any buttons/triggers/sticks. Well, pressing the “B” button on the Xbox controller behaved like pressing the Android back button. Also the Xbox mappings were pretty bad. I used an app called GamepadTester and pressing the R or L Triggers also activated the right thumbstick. Thankfully I found the correct keylayout file and I was able to fix it. Now the Xbox BT Controller behaves correctly on the GamepadTester but it still doesn’t work on those 2 games.

Normally the same GamepadTest app will allow to modify/create keylayout files but it requires App Root Access (I don’t know how to enable SuperSU on the TinkerBoard). The fix was pretty simple:
Step1: Open an ADB shell to mount /system writable
Step2: Push the fixed/modified .kl (keylayout file -see below for details) from my computer to system/usr/keylayout.
Step3: Open ADB Shell to restore or mount /system read-only
Step4: Reboot TinkerBoard (maybe optional or not needed).

*I can post the ADB/Shell commands I used if some needs them. Just reply to this post and let me know.*

Since I’m using the Xbox One S Bluetooth Gamepad Model 1708 the file is named: Vendor_045e_Product_02fd.kl

I forgot the link to directly download the .kl file but I do have the link to the AOSP-Mirror on GitHub:

I really want to enjoy Android gaming on the TinkerBoard with the Xbox or Emtec gamepads. Any help will be appreciated.

Forum Jump:

Users browsing this thread: 1 Guest(s)