This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Static IP - TOS 1.8
#1
Hey guys,
I'm new to this forum and to linux/TB in general, so please forgive me if I say/ask something ignorant. 

I'm trying to set up a static IP for my tinkerboard, and the tutorials i've found all say to edit /etc/network/interfaces and edit the eth0, but I cant find that in interfaces. This is what the interfaces file does say:

# interfaces(5) file used by ifup(8) and ifdown(8)

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

Any help would be greatly appreciated!

Raaabiiin
Reply
#2
Hey Melissa 
[admin edit] deleted spammer
Thanks for the reply, but i'm not sure how this helps me. 

 I know what an IP address is and what a static IP address does, but I don't know how to make my ip address static. 

Since I use an SSH connection to remote into it locally, a power outage will reset my router and possibly assign new dynamic IP addresses to my devices, meaning I can't reliably remote into it without having to go through the trouble of checking the connected devices and their ip address through the router.
Reply
#3
Side solution: Could you assign a Static IP at the ROUTER Level? Look into the DHCP functions of the router, assign a static IP to the MAC number of your Tinkerboard IP interface(s) Ethernet and/or wifi.

OR from the TB side, For me on TOS 6 these settings did work https://wiki.debian.org/NetworkConfigura...e_manually
Reply
#4
Make sure your static ip should be secure from spammer and hackers. The dynamic ip address makes your device and profile secure. you have to know how you can to set a proper ip address. the ip address secure and save your data at the time of power outage. to make interface strong set your ip address properly.

thank you for the info this is so valuable.

this is so good article to read.

this is good to know. thank you for post this article is so useful.
Reply
#5
Quote:The dynamic ip address makes your device and profile secure.
Who told you that? Port scanners will find you with or without a dynamic IP. Private IPs (static or dynamic behind a router) will help protect you.
Reply
#6
hi Raaabiiin...

this is what I used to do to fix IP..
----------------------------------------
on first boot.. 
1. 
Code:
sudo su  
apt-get update
apt-get upgrade
note.. DO NOT run apt-get dist-upgrade
THIS WILL BREAK Tinkerboard....

2. check system..
Code:
uname -a
Linux linaro-alip 4.4.71+ #1 SMP Thu Aug 17 00:28:01 CST 2017 armv7l GNU/Linux

cat /proc/version
Linux version 4.4.71+ (jenkins@fdc-06) (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.4) ) #1 SMP Thu Aug 17 00:28:01 CST 2017

cat /etc/issue
Debian GNU/Linux 9 \n \l

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.1 (stretch)
Release:        9.1
Codename:       stretch

3. setup hostname, #### press i to edit,
Code:
vi /etc/hostname
tinker01-tek
then [esc] :wq to save and exit

4. SETUP IP.. (fix IP to 192.168.0.200,) [dns  8.8.8.8, 4.4.4.4 search 192.168.0.1]
Code:
cat /etc/dhcpcd.conf

note..
# Set Static IP for eth0
nohook lookup-hostname
interface eth0
static ip_address=192.168.0.200/24
static routers=192.168.0.1
static domain_name_servers=8.8.8.8 4.4.4.4
#static domain_search=example.com
#static domain_name=example.com
-------------------------------------------
use nano /etc/dhcpcd.conf

you might have to install nano first.. 
sudo apt install nano

last....
fix ping   http://words.mikek.systems/?p=40
------------------------------------------------------
ls -la /bin/ping
-rwxr-xr-x 1 root root 47756 Nov 10  2016 /bin/ping
---------------  Run as Norm user & not ROOT ####

sudo chmod 4755 /bin/ping

now test ping..
ping google.com

then... 
sudo reboot
------------------ ;-]..
hope it helps,
k,
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)