This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HDMI resolution issue on 5:4 (4:3) displays

Im trying to mate my non-wide touchscreen 19" 5:4 native 1280x1024 @60/75Hz with TinkerboardS HDMI on Android.
Both images - from asus site and compiled tinkerboard/asus/Android-7.1.2 have same issue:
all screen elements (icons, etc) are squeezed in width.
It seems that system are trying to fit widescreen resolution (1920x1080 by default) into a square screen (5:4)
I tried to resize resolution via Settings/Display/HDMI/Resolution and via adb shell wm size, but with no luck -
resolution changes, but i got black bars on the left/right sides of the screen and still distorted icons shape.

After adb shell wm size 1280x1024 command i got
Physical size: 1920x1080
Override size: 1280x1024
Is there any way to change "physical" resolution on asus image or in sources?
btw, Raspberry Pi 4 scales correctly.

To revert the change:
adb connect 192.168.1.X
adb shell wm size reset
adb shell wm density reset
adb reboot

have you tried.. 
setprop persist.sys.resolution.main 1280x1024@60
setprop sys.display.timeline 1

from Tinker Boards post #3 on Change Resolution thread ?

note.. you will need system /VM connected to same LAN with adb installed..
adb connect IP
adb root
adb connect IP
adb remount
adb shell
then you can use.. setprop persist.sys.resolution.main..

hope it helps,
Thanks for your recommendations, but it didn't help.
The link explains how to reset/change the resolution, but i can do it without problems.
Moreover, at the moment when I change resolution, I even see for half a second how the icons become round,
but then some kind of recalculation of the screen rez happens and screen is compressed again (width).

I think this error is somewhere in the source code.
I changed the line
but didn't help
There is also an array that contains lines of this kind
This suggests that somewhere there this is happening... 4_3, 16_9

It is strange that the developers did not test this mode, because HDMI assumes the use of monitors with any standard aspect ratio
Can I write directly to the asus. Does anyone know the right address of the tech support for this issue?

Any other thoughts?
hi carrera,

maybe try.. play with setprop persist.sys.overscan.main... 
$ adb shell getprop persist.sys.overscan.main
overscan 100,100,100,100

& from [Display menu]  [HDMI].. there is also [ScreenZoom]

other then this.. a deeper dive into this forum is required ;-]..
found a post by lobo.. on The default resolution the driver uses.. & finding the right timings.. 
more links.. My screen is weird..
from.. 7" HDMI screen flickers.. post #4
from.. 1680x1050 resolution black screen.. post #8
from.. 5 inch HDMI screen advice?.. post #2
note.. Adding a custom display
note.. Why did Super-VGA offer the 5:4 1280×1024 resolution?
note.. Graphics display resolution1280 × 1024 (SXGA)

re-reading this.. is hurting my head ]]].. you might have better luck with it..

hope it helps,
Hi Carrera,

You can try following steps:
Via ADB command or type command via UART console to change resolution to 1024x768 60FPS.

(1) su
(2) setprop persist.sys.resolution.main 1024x768@60
(3) setprop sys.display.timeline 1
(4) stop
(5) start

P.S. every time set a new resolution sys.display.timeline need to plus 1

for example if add 1st "persist.sys.resolution.main" as 1024x768@60, then sys.display.timeline set as 1
then if add another new one (2nd) to "persist.sys.resolution.main" as 800x600@60, than that sys.display.timeline need set as 2

To whom it may concerns.
None of above commands helped me.
Thus, I have contacted with Asus tech support specialist Fred Yu (
As a result of our correspondence I got an image from Fred, which includes support
for my USB Touchscreen Elo 2700 and support for square displays.

At the end of our communication, he wrote to me:
From our point of view, the USB touchscreen should not be a problem to implement into the official image. However, regarding the 4:3 screen, we might need more consideration to support this kind of size.
UPDATE (2020/11/30):
He wrote:
After the internal investigation and discussion, we will implement these solutions to the official release image for Tinker Board /S in future.

Thanks to everyone who participated

Forum Jump:

Users browsing this thread: 1 Guest(s)