This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Disable usb gadget / usb ums
#1
Question 
Hello everyone,

this is my first post to this forum Smile

Is there a way to disable the usb gadget feature (Tinkerboard S eMMC mounts as block device, when connected to a PC)?
I read that there might be a way by configuring U-Boot but I couldn't figure out how to access that.
I am running the image 20190821-tinker-board-linaro-stretch-alip-v2.0.11.img

I've been using the Beagle Bone Black before switching to the Tinker Board S and the Beagle Bone Black also uses usb gadget. It can be deactivated by
commenting out a few lines of code in one of the startup bash scripts.
Maybe it is possible on the Tinker Board S too?

I really need to disable this feature because of security requirements for my type of applications. It would be detrimental to the security in my environment if someone could access
the files and data on the device by simply connecting it to a PC.

Thank you so much in advance!

Greetings,
Mario
Reply
#2
1.
https://github.com/armbian/build
2. Build without UMS related patches
https://github.com/armbian/build/tree/ma...inkerboard
Armbian. Lightweight Debian Stretch or Ubuntu Bionic for Tinker Board.
Reply
#3
(01-13-2021, 12:00 AM)mkleine Wrote: Hello everyone,

this is my first post to this forum Smile

Is there a way to disable the usb gadget feature (Tinkerboard S eMMC mounts as block device, when connected to a PC)?
I read that there might be a way by configuring U-Boot but I couldn't figure out how to access that.
I am running the image 20190821-tinker-board-linaro-stretch-alip-v2.0.11.img

I've been using the Beagle Bone Black before switching to the Tinker Board S and the Beagle Bone Black also uses usb gadget. It can be deactivated by
commenting out a few lines of code in one of the startup bash scripts.
Maybe it is possible on the Tinker Board S too?

I really need to disable this feature because of security requirements for my type of applications. It would be detrimental to the security in my environment if someone could access
the files and data on the device by simply connecting it to a PC.

Thank you so much in advance!

Greetings,
Mario

You can try this patch to Disable UMS directly. We are also working on a configuration for this.
https://github.com/TinkerBoard/debian_u-...af3b2f44e9
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)