This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tried to update pigpiod - no way to go back?
#1
Hi,

I'm just trying to transfer a extisting project to the TinkerOS.
On this project we're using the npm pakage "pigpiod" to use the interupt function for the GPIOs.
I'm struggeling with this for a few weeks now, but didn't find a good way to go.

I tried a lot of things until now.

and today i ended up with "initPeripherals: mmap gpio failed (Operation not permitted)"

My last idea was to update PIGPIOD on TinkerOS (I think it is v63) to a newer one because I got "sighandler unhandled signal 11 terminating" and found an information that this is fixed in newer PiGPIO versions.

I tried this first:

Code:
wget https:// github.com/joan2937/pigpio/archive/master.zip
unzip master.zip
cd pigpio-master
make
sudo make install

After updated to the actual "master" version i received the "initPeripherals: mmap gpio failed (Operation not permitted)" error for the first time.
So I tried to go back to the ASUS Package but it didn't work:

Code:
git clone http: // github.com/TinkerBoard/gpio_lib_c --depth 1 GPIO_API_for_C

cd GPIO_API_for_C/
sudo chmod +x build

sudo ./build

I'm on v7x (don't know the correct number) 
So i switched to V66 also with the mmap error

Code:
wget https: // github.com/joan2937/pigpio/archive/V66.tar.gz
tar -xvzf V66.tar.gz
cd pigpio-66/
make
sudo make install

Does anybody know how to go back to the standard one?

I also tried armbian before everything and ended up with "initPeripherals: mmap gpio failed (Operation not permitted)", everytime.

Also added "iomem=relaxed" to cmdline on TinkerOS and on Armbian.
Did I miss something?
Reply
#2
I think that is because pigpio is designed for RPi Broadcom processor.
https://github.com/joan2937/pigpio#gpio
Quote:ALL GPIO are identified by their Broadcom number. See http://elinux.org.
There are 54 GPIO in total, arranged in two banks.
Bank 1 contains GPIO 0-31. Bank 2 contains GPIO 32-54.

So I think, need to find GPIO pin number been defined in which codes...
And change to meet Tinker's.

But there may be more than that since this project looks a bit like it was made for Broadcom, which may not be a generic Linux GPIO control method.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)