This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No Sound on Thinkerboard Asus
#11
(08-06-2017, 10:57 PM)zlham Wrote: Huh I have the same problem. No sound to the headphone jack from any media player or from the web browser. 

aplay -l says that the USB audio device is 0,2 for output and 0,1 for input. If I send audio to the port using aplay -D command it plays. If I use piHPSDR set to audio out on hw:0,2 it plays fine. But Pulse Audio does not send audio to the headphone jack.

On the volume control tab, the USB audio is set to Headphones. There are no other options. I have Roc chip turned off, but it makes no difference if it is set on. I can see the audio playing on the bar graph just above the word Advanced on the volume control, so Pulse Audio is seeing the audio stream but it is not sending it to hw:0,2 and there seems to be no way to make it do that. 

If I plug in a USB input device (FunCube Dongle receiver) then the USB audio changes from card hw:0,2 to card hw:1,2, but PiHPSDR program adjusts automatically and still works. I still get no audio from the headphone jack.

If I plug in a SoundBlaster USB sound card I can get audio out of the media players and web browser, but still not from the headphone jack.

HELP!! I have wasted hours on this!
Try these 4 steps.  Only answer these questions.  Don't add anything else. I may get confused.
1 Do you have smplayer installed? 
   If so run a mp3 or mp4 file.
2 While smplayer is running go to the Pulse Audio Playback tab.  Don't look at any other tabs.
   Do you see the smplayer volume level moving? 
   You should see the mpv Media Player.
3 Click the button to the right of that.
   Change it to headset.
4 Go to the configuration tab to the far right. In rockship....profile select analog stereo output
   Do you hear sound in your earphones?

Answer this for me.  Did you succeed on all 4 steps?  If not, which step?

You will have to set all sound applications this way. VLC, Youtube, Smplayer, and any other apps that use sound.
Reply
#12
(08-07-2017, 12:03 AM)Jay Smith Wrote:
(08-06-2017, 10:57 PM)zlham Wrote: Huh I have the same problem. No sound to the headphone jack from any media player or from the web browser. 

aplay -l says that the USB audio device is 0,2 for output and 0,1 for input. If I send audio to the port using aplay -D command it plays. If I use piHPSDR set to audio out on hw:0,2 it plays fine. But Pulse Audio does not send audio to the headphone jack.

On the volume control tab, the USB audio is set to Headphones. There are no other options. I have Roc chip turned off, but it makes no difference if it is set on. I can see the audio playing on the bar graph just above the word Advanced on the volume control, so Pulse Audio is seeing the audio stream but it is not sending it to hw:0,2 and there seems to be no way to make it do that. 

If I plug in a USB input device (FunCube Dongle receiver) then the USB audio changes from card hw:0,2 to card hw:1,2, but PiHPSDR program adjusts automatically and still works. I still get no audio from the headphone jack.

If I plug in a SoundBlaster USB sound card I can get audio out of the media players and web browser, but still not from the headphone jack.

HELP!! I have wasted hours on this!
I will try to help you.  Only answer these questions.  Don't add anything else. I may get confused.
1 Do you have smplayer installed? 
   If so run a mp3 or mp4 file.
2 While smplayer is running go to the Pulse Audio Playback tab.  Don't look at any other tabs.
   Do you see the smplayer volume level moving? 
   You should see the mpv Media Player.
3 Click the button to the right of that.
   Change it to headset.
   Do you hear sound in your earphones?

Answer this for me.  Did you succeed on all 3 steps?  If not, which step?

Thanks. 1 no, but I installed it for the test.

2. smplayer plays the MP4 and I can see the video but there is no sound from the jack.

3. I can see the mp4 audio on the bar graph, but there is no audio output to the headphone jack.

I don't have a pulse audio playback tab just an  'out put devices' one. On the volume control I only see "USB audio analog stereo." It is set to "headphones" (no other choice available).
Reply
#13
(08-07-2017, 04:44 AM)zlham Wrote:
(08-07-2017, 12:03 AM)Jay Smith Wrote:
(08-06-2017, 10:57 PM)zlham Wrote: Huh I have the same problem. No sound to the headphone jack from any media player or from the web browser. 

aplay -l says that the USB audio device is 0,2 for output and 0,1 for input. If I send audio to the port using aplay -D command it plays. If I use piHPSDR set to audio out on hw:0,2 it plays fine. But Pulse Audio does not send audio to the headphone jack.

On the volume control tab, the USB audio is set to Headphones. There are no other options. I have Roc chip turned off, but it makes no difference if it is set on. I can see the audio playing on the bar graph just above the word Advanced on the volume control, so Pulse Audio is seeing the audio stream but it is not sending it to hw:0,2 and there seems to be no way to make it do that. 

If I plug in a USB input device (FunCube Dongle receiver) then the USB audio changes from card hw:0,2 to card hw:1,2, but PiHPSDR program adjusts automatically and still works. I still get no audio from the headphone jack.

If I plug in a SoundBlaster USB sound card I can get audio out of the media players and web browser, but still not from the headphone jack.

HELP!! I have wasted hours on this!
I will try to help you.  Only answer these questions.  Don't add anything else. I may get confused.
1 Do you have smplayer installed? 
   If so run a mp3 or mp4 file.
2 While smplayer is running go to the Pulse Audio Playback tab.  Don't look at any other tabs.
   Do you see the smplayer volume level moving? 
   You should see the mpv Media Player.
3 Click the button to the right of that.
   Change it to headset.
   Do you hear sound in your earphones?

Answer this for me.  Did you succeed on all 3 steps?  If not, which step?

Thanks. 1 no, but I installed it for the test.

2. smplayer plays the MP4 and I can see the video but there is no sound from the jack.

3. I can see the mp4 audio on the bar graph, but there is no audio output to the headphone jack.

I don't have a pulse audio playback tab just an  'out put devices' one. On the volume control I only see "USB audio analog stereo." It is set to "headphones" (no other choice available).
 In number 2 make sure that smplayer is open and it is streaming audio.
So you don't see the first tab which is Playback?  There is a little left arrow to the left of Output Device.  Click on that it should move to the first tab.......playback. You must have a Playback tab or you can't make adjustments.

Make sure the Configuration Tab has Rockchip codec profile is set to analog strereo ouput.
Reply
#14
(08-07-2017, 02:41 PM)Jay Smith Wrote:
(08-07-2017, 04:44 AM)zlham Wrote:
(08-07-2017, 12:03 AM)Jay Smith Wrote:
(08-06-2017, 10:57 PM)zlham Wrote: Huh I have the same problem. No sound to the headphone jack from any media player or from the web browser. 

aplay -l says that the USB audio device is 0,2 for output and 0,1 for input. If I send audio to the port using aplay -D command it plays. If I use piHPSDR set to audio out on hw:0,2 it plays fine. But Pulse Audio does not send audio to the headphone jack.

On the volume control tab, the USB audio is set to Headphones. There are no other options. I have Roc chip turned off, but it makes no difference if it is set on. I can see the audio playing on the bar graph just above the word Advanced on the volume control, so Pulse Audio is seeing the audio stream but it is not sending it to hw:0,2 and there seems to be no way to make it do that. 

If I plug in a USB input device (FunCube Dongle receiver) then the USB audio changes from card hw:0,2 to card hw:1,2, but PiHPSDR program adjusts automatically and still works. I still get no audio from the headphone jack.

If I plug in a SoundBlaster USB sound card I can get audio out of the media players and web browser, but still not from the headphone jack.

HELP!! I have wasted hours on this!
I will try to help you.  Only answer these questions.  Don't add anything else. I may get confused.
1 Do you have smplayer installed? 
   If so run a mp3 or mp4 file.
2 While smplayer is running go to the Pulse Audio Playback tab.  Don't look at any other tabs.
   Do you see the smplayer volume level moving? 
   You should see the mpv Media Player.
3 Click the button to the right of that.
   Change it to headset.
   Do you hear sound in your earphones?

Answer this for me.  Did you succeed on all 3 steps?  If not, which step?

Thanks. 1 no, but I installed it for the test.

2. smplayer plays the MP4 and I can see the video but there is no sound from the jack.

3. I can see the mp4 audio on the bar graph, but there is no audio output to the headphone jack.

I don't have a pulse audio playback tab just an  'out put devices' one. On the volume control I only see "USB audio analog stereo." It is set to "headphones" (no other choice available).
 In number 2 make sure that smplayer is open and it is streaming audio.
So you don't see the first tab which is Playback?  There is a little left arrow to the left of Output Device.  Click on that it should move to the first tab.......playback. You must have a Playback tab or you can't make adjustments.

Make sure the Configuration Tab  has Rockchip codec profile is set to analog strereo ouput.

Yep OK I did that and I now see mpv player streaming the audio. I see the audio level changing on the bar meter. But still no sound coming out the headphone jack. I think that the problem is that Pulse Audio has not selected the right hardware ie hw:0,2. If I turn off USB audio and plug in my SoundBlaster USB device, it works through that. But no matter what I do the headphone jack refuses to work. I know that others report that the jack does work under android, but not Debian Tinker OS. I can get audio from the jack if I send a file directly to hw:0,2. So the hardware works OK. I believe that it is a fault with either Tinker OS or Pulse Audio.
Reply
#15
(08-08-2017, 03:10 AM)zlham Wrote:
(08-07-2017, 02:41 PM)Jay Smith Wrote:
(08-07-2017, 04:44 AM)zlham Wrote:
(08-07-2017, 12:03 AM)Jay Smith Wrote:
(08-06-2017, 10:57 PM)zlham Wrote: Huh I have the same problem. No sound to the headphone jack from any media player or from the web browser. 

aplay -l says that the USB audio device is 0,2 for output and 0,1 for input. If I send audio to the port using aplay -D command it plays. If I use piHPSDR set to audio out on hw:0,2 it plays fine. But Pulse Audio does not send audio to the headphone jack.

On the volume control tab, the USB audio is set to Headphones. There are no other options. I have Roc chip turned off, but it makes no difference if it is set on. I can see the audio playing on the bar graph just above the word Advanced on the volume control, so Pulse Audio is seeing the audio stream but it is not sending it to hw:0,2 and there seems to be no way to make it do that. 

If I plug in a USB input device (FunCube Dongle receiver) then the USB audio changes from card hw:0,2 to card hw:1,2, but PiHPSDR program adjusts automatically and still works. I still get no audio from the headphone jack.

If I plug in a SoundBlaster USB sound card I can get audio out of the media players and web browser, but still not from the headphone jack.

HELP!! I have wasted hours on this!
I will try to help you.  Only answer these questions.  Don't add anything else. I may get confused.
1 Do you have smplayer installed? 
   If so run a mp3 or mp4 file.
2 While smplayer is running go to the Pulse Audio Playback tab.  Don't look at any other tabs.
   Do you see the smplayer volume level moving? 
   You should see the mpv Media Player.
3 Click the button to the right of that.
   Change it to headset.
   Do you hear sound in your earphones?

Answer this for me.  Did you succeed on all 3 steps?  If not, which step?

Thanks. 1 no, but I installed it for the test.

2. smplayer plays the MP4 and I can see the video but there is no sound from the jack.

3. I can see the mp4 audio on the bar graph, but there is no audio output to the headphone jack.

I don't have a pulse audio playback tab just an  'out put devices' one. On the volume control I only see "USB audio analog stereo." It is set to "headphones" (no other choice available).
 In number 2 make sure that smplayer is open and it is streaming audio.
So you don't see the first tab which is Playback?  There is a little left arrow to the left of Output Device.  Click on that it should move to the first tab.......playback. You must have a Playback tab or you can't make adjustments.

Make sure the Configuration Tab  has Rockchip codec profile is set to analog strereo ouput.

Yep OK I did that and I now see mpv player streaming the audio. I see the audio level changing on the bar meter. But still no sound coming out the headphone jack. I think that the problem is that Pulse Audio has not selected the right hardware ie hw:0,2. If I turn off USB audio and plug in my SoundBlaster USB device, it works through that. But no matter what I do the headphone jack refuses to work. I know that others report that the jack does work under android, but not Debian Tinker OS. I can get audio from the jack if I send a file directly to hw:0,2. So the hardware works OK. I believe that it is a fault with either Tinker OS or Pulse Audio.



step 4 Did you go to the Configuration Tab and set Rockchip codec profile is set to analog strereo ouput. I would think you did.

step 5 You may have to reinstall the OS. And before updating and editing anything get the smplayer/youtube headset going.
My headset and HDMI audio from my TV is working. I can switch between them.

step 6 connect to an hdmi tv and select the rockchip. See if sound appears with a tv.

step 7 You can try to edit /etc/pulse/default.pa
I am able to resolve pavucontrol issue by doing all this:

**********************************
sudo apt-get purge pulseaudio
sudo apt-get clean && sudo apt-get autoremove
Reboot. Open a terminal again and type (ignore any errors with the rm command):

rm -r ~/.pulse ~/.asound* ~/.pulse-cookie ~/.config/pulse
sudo apt-get install pulseaudio
sudo alsa force-reload
pavucontrol


step 8 You can try with modify /etc/pulse/default.pa to fix this issue.
See headset below. This maybe what you are thinking it could be with hw:1,2
#load-module module-alsa-sink
load-module module-alsa-sink device=hw:1,0 sink_properties=device.description="BT_VOIP-Output"
load-module module-alsa-sink device=hw:1,1 sink_properties=device.description="SPDIF-Output"
load-module module-alsa-sink device=hw:1,2 sink_properties=device.description="Headset-Output"
#load-module module-alsa-source device=hw:1,0
load-module module-alsa-source device=hw:1,0 source_properties=device.description="BT_VOIP-Input"
load-module module-alsa-source device=hw:1,1 source_properties=device.description="Headset-Input"

Your options are try and edit the file above or Re-install and get the headset to work.
Run a youtube video with audio and you should see youtube in the playback tab. Switch it to headset and see if there is sound.
Another one is I installed fresh and did a update and upgrade only once. If you do an update/upgrade again, the xserver-xorg system will update
and can cause problems. So only do one apt-get update/upgrade. So, in synaptic I did the second update and saw the xserver-xorg and selected it and in the package menu checked blocked version so it won't update. It destroyed kodi and can cause some other problems. There was two others and blocked them too. I can't remember them.
Then set the headset again. That's all I can think of. I think you maybe close to getting it. Hay, we are working with a brand new beta system. It's not perfect. I fixed several things already. It just comes from living with it and looking for help from others.

I like it. I have youtube/internet, kodi. and most of my favorite applications.
Reply
#16
(08-07-2017, 12:03 AM)Jay Smith Wrote:
(08-06-2017, 10:57 PM)zlham Wrote: Huh I have the same problem. No sound to the headphone jack from any media player or from the web browser. 

aplay -l says that the USB audio device is 0,2 for output and 0,1 for input. If I send audio to the port using aplay -D command it plays. If I use piHPSDR set to audio out on hw:0,2 it plays fine. But Pulse Audio does not send audio to the headphone jack.

On the volume control tab, the USB audio is set to Headphones. There are no other options. I have Roc chip turned off, but it makes no difference if it is set on. I can see the audio playing on the bar graph just above the word Advanced on the volume control, so Pulse Audio is seeing the audio stream but it is not sending it to hw:0,2 and there seems to be no way to make it do that. 

If I plug in a USB input device (FunCube Dongle receiver) then the USB audio changes from card hw:0,2 to card hw:1,2, but PiHPSDR program adjusts automatically and still works. I still get no audio from the headphone jack.

If I plug in a SoundBlaster USB sound card I can get audio out of the media players and web browser, but still not from the headphone jack.

HELP!! I have wasted hours on this!
I will try to help you.  Only answer these questions.  Don't add anything else. I may get confused.
1 Do you have smplayer installed? 
   If so run a mp3 or mp4 file.
2 While smplayer is running go to the Pulse Audio Playback tab.  Don't look at any other tabs.
   Do you see the smplayer volume level moving? 
   You should see the mpv Media Player.
3 Click the button to the right of that.
   Change it to headset.
   Do you hear sound in your earphones?

Answer this for me.  Did you succeed on all 3 steps?  If not, which step?
OK I fixed it. Its a bit unusual but it worked.
1. in /etc/pulse edit default.pa (you need sudo access).

2. at the bottom of the section marked "load audio divers statically" assuming that you have found that the audio output should be hw:0,2 add the line 
load-module module-alsa-sink device =hw:0,2

3. right at the bottom of the file where it says "make some devices default" add a line
set-default-sink device=hw:0,2

4. save the file. Note that sometimes this editing stops the volume control screen from working, but it sorts itself out and restarts after a minute or two.

5. in the Configuration tab of PulseAudio volume control set both rockchip.miniarm-codec and USB Audio to OFF. Now the audio to the headphone jack works. Yeah I know that technically nothing is set in the config screen... but it works! You can even set the volume on the playback and output devices tabs.
Reply
#17
(08-08-2017, 10:06 AM)zlham Wrote:
(08-07-2017, 12:03 AM)Jay Smith Wrote:
(08-06-2017, 10:57 PM)zlham Wrote: Huh I have the same problem. No sound to the headphone jack from any media player or from the web browser. 

aplay -l says that the USB audio device is 0,2 for output and 0,1 for input. If I send audio to the port using aplay -D command it plays. If I use piHPSDR set to audio out on hw:0,2 it plays fine. But Pulse Audio does not send audio to the headphone jack.

On the volume control tab, the USB audio is set to Headphones. There are no other options. I have Roc chip turned off, but it makes no difference if it is set on. I can see the audio playing on the bar graph just above the word Advanced on the volume control, so Pulse Audio is seeing the audio stream but it is not sending it to hw:0,2 and there seems to be no way to make it do that. 

If I plug in a USB input device (FunCube Dongle receiver) then the USB audio changes from card hw:0,2 to card hw:1,2, but PiHPSDR program adjusts automatically and still works. I still get no audio from the headphone jack.

If I plug in a SoundBlaster USB sound card I can get audio out of the media players and web browser, but still not from the headphone jack.

HELP!! I have wasted hours on this!
I will try to help you.  Only answer these questions.  Don't add anything else. I may get confused.
1 Do you have smplayer installed? 
   If so run a mp3 or mp4 file.
2 While smplayer is running go to the Pulse Audio Playback tab.  Don't look at any other tabs.
   Do you see the smplayer volume level moving? 
   You should see the mpv Media Player.
3 Click the button to the right of that.
   Change it to headset.
   Do you hear sound in your earphones?

Answer this for me.  Did you succeed on all 3 steps?  If not, which step?
OK I fixed it. Its a bit unusual but it worked.
1. in /etc/pulse edit default.pa (you need sudo access).

2. at the bottom of the section marked "load audio divers statically" assuming that you have found that the audio output should be hw:0,2 add the line 
load-module module-alsa-sink device =hw:0,2

3. right at the bottom of the file where it says "make some devices default" add a line
set-default-sink device=hw:0,2

4. save the file. Note that sometimes this editing stops the volume control screen from working, but it sorts itself out and restarts after a minute or two.

5. in the Configuration tab of PulseAudio volume control set both rockchip.miniarm-codec and USB Audio to OFF. Now the audio to the headphone jack works. Yeah I know that technically nothing is set in the config screen... but it works! You can even set the volume on the playback and output devices tabs.
Ok good.  I copied and saved your work  I could have the same issue next time I reinstall.
Save it all to a text file.



Here is the finished steps to get audio working.
No sound in TInkerOS Debian v1.9.
Only answer these questions. Don't add anything else. I may get confused.
1 Do you have smplayer installed? Install if needed.
Run a audio file mp3 or mp4 file.
2 While smplayer is running and streaming audio go to the Pulse Audio Playback tab.
Do you see the smplayer volume level moving? You should see the mpv Media Player.
If you don't see the first tab which is Playback, there is a little left arrow to the left of the other tabs. Click on that it should move left to the first tab....playback.
You must have a Playback tab or you can't make adjustments.
3 Once you see the playback tab you should see mpv Media Player...on
Click the button to the right of that.
Change it to headset.
Do you hear sound in your earphones?
If no sound, go to the configuration tab>rockchip profile and set it to analog stereo output.

Did you succeed on all 3 steps? If not, go to step 4.
Note: you can also run youtube video with audio streaming and it will show in the playback tab.

4. In /etc/pulse edit default.pa (you need sudo access).
5. At the bottom of the section marked "load audio divers statically" assuming that you have found that the audio output should be hw:0,2 add the line
load-module module-alsa-sink device =hw:0,2
6. right at the bottom of the file where it says "make some devices default" add a line
set-default-sink device=hw:0,2
7. save the file. Note that sometimes this editing stops the volume control screen from working, but it sorts itself out and restarts after a minute or two.
8. in the Configuration tab of PulseAudio volume control set both rockchip.miniarm-codec and USB Audio to OFF. Now the audio to the headphone jack works. Yeah I know that technically nothing is set in the config screen... but it works! You can even set the volume on the playback and output devices tabs.
Reply
#18
I modify /usr/share/alsa/alsa.conf and ~/.asoundrc.  (reference: https://www.alsa-project.org/main/index.php/Asoundrc), and sonic-pi has sound to run an example.

This is my steps to fix the issue shown as following.
Step 1. using "aplay -l " and list the result.

**** List of PLAYBACK Hardware Devices ****
card 0: Audio [USB Audio], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Audio [USB Audio], device 1: USB Audio [USB Audio #1]#
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [USB Audio], device 2: USB Audio [USB Audio #2]#
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: rockchipminiarm [rockchip,miniarm-codec], device 0: ff890000.i2s-i2s-hifi i2s-hifi-0 []#
  Subdevices: 1/1
  Subdevice #0: subdevice #0

* More detail:
Card 0, device 0: BT_VOIP
Card 0, device 1: SPDIF
Card 0, device 2: Headset
Card 1: HDMI

Step 2. Modify /usr/share/alsa/alsa.conf (sudo vim /usr/share/alsa/alsa.conf)
Method 1: set as Headset

Code:
defaults.pcm.card 0
defaults.pcm.device 2

Method 2: set as HDMI
Code:
defaults.pcm.card 1
defaults.pcm.device 0


Step 3. Create ~/.asoundrc (vim ~/.asoundrc)
Method 1: set as Headset
Code:
pcm.!default {
type hw
card 0
device 2
}

ctl.!default {
type hw          
card 0
device 2
}

Method 2: set as HDMI

Code:
pcm.!default {
type hw
card 1
}

ctl.!default {
type hw          
card 1
}

Step 4. sonic-pi
Reply
#19
Hi Guys sorry for the long delay in replying back this was due to me completing my final year of my degree course.

Okay since I install the latest version of the Asus Tinker Board  Latest version v2.0.1 - Debian stretch based. 2017/08/21 OS 

my sound problem has now been fix and it works like a dream 
Reply
#20
(10-19-2017, 01:14 PM)waheedrafiq Wrote: Hi Guys sorry for the long delay in replying back this was due to me completing my final year of my degree course.

Okay since I install the latest version of the Asus Tinker Board  Latest version v2.0.1 - Debian stretch based. 2017/08/21 OS 

my sound problem has now been fix and it works like a dream 

What was the fix for your audio?  Please share.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)