This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RetroPie on the Tinker Board
what you on about boot/pwd .... it boots directly to Emulationstation ... you then launch lxde desktop from the carouselle ... it doesnt ask for a boot password or any other password ... what are you trying to do?
[Image: ROTT_1_Logo.png]
Reply
RotT 0.6.5.

Changes:

Clean intro
Splash screen
Boot video
Background music
Music -on and music -off toggles
Some on board scripts that need to be tested.
Wifi from retropie menu (toolkit)
Added Crash theme
Added Carbon purple heat theme

If the HDD scripts work it is the Easy Hax method.

Music located in the roms folder


https://drive.google.com/file/d/13-i5N3a...sp=sharing
Swing by the: RotT FaceBook Group and join for even more help, trick, and tips.

Swing by My YouTube Channel if you get a chance.

Reply
Hello, first of all a very big thank you for your work.I have a small problem that you could help me solve. I use a screen pc hdmi without speaker. I want to activate the sound when emulating the game on the output jack 3.5, I used the command "sudo nano /etc/asound.conf"

pcm.! default {
plug type
slave {
pcm "hw: 0.2"
}
}
ctl.! default {
type hw
card 0
}
I have some sound on the jack during the boot of the video and a music of zelda in the retropie menu but when emulating games nothing. I presume that if I plug the tinkerboard on the tv in hdmi, I have his ingame on the speaker of the tv and the music on the jack. thank you in advance for your help
Reply
(02-12-2018, 09:05 PM)kikego Wrote: Hello, first of all a very big thank you for your work.I have a small problem that you could help me solve. I use a screen pc hdmi without speaker. I want to activate the sound when emulating the game on the output jack 3.5, I used the command "sudo nano /etc/asound.conf"

pcm.! default {     <------- no space between ! d---->  pcm.!default {
plug type
slave {
pcm "hw: 0.2"     <------- not a . but a , ----> pcm "hw: 0,2"
}
}
ctl.! default {        <------- no space between ! d ---->  ctl.!default {
type hw
card 0
}
I have some sound on the jack during the boot of the video and a music of zelda in the retropie menu but when emulating games nothing. I presume that if I plug the tinkerboard on the tv in hdmi, I have his ingame on the speaker of the tv and the music on the jack. thank you in advance for your help
If that doesn't work for you try this from Richard and his handheld set up.

"This is a quick tutorial on how to get sound output from the 3.5mm audio jack. 
I am using my TinkerBoard in a handheld build, so I only need sound output from the 3.5 jack.


Putty into the Tinker Board and navigate to /etc/pulse.
You will modify the file named: default.pa
Type
sudo nano default.pa

Scroll to the bottom until you see this line:
set-default-sink alsa_output.platform-sound-simple-card.analog-stereo

Change it to this: 
set-default-sink alsa_output.Onboard_D2

Save and reboot. 
You should now have sound for your boot up video, menu, games, and kodi if you have speakers hooked up through the 3.5mm audio jack." - Richard


I personally have not tried this but Richard posted a Video and showed the changes, and it was coming out of the handheld.
Swing by the: RotT FaceBook Group and join for even more help, trick, and tips.

Swing by My YouTube Channel if you get a chance.

Reply
I spent 6hrs on this last night, but is there a way to force the TB to output 1080@60fps on a 4k screen, I tried adding the option in config.txt in the /boot dir but it still boots up in 4k everytime. It boots up to Emulation station in 4k but drops to 1080p when dropping to the Linaro desktop. Just want the ES bootup to be 1080 as well.

Thanks in advance!
Reply
Now comes the daunting task of setting up the emulator configs.  This is RotT v0.6.5
 


(02-13-2018, 04:16 PM)Vruasix Wrote: I spent 6hrs on this last night, but is there a way to force the TB to output 1080@60fps on a 4k screen, I tried adding the option in config.txt in the /boot dir but it still boots up in 4k everytime. It boots up to Emulation station in 4k but drops to 1080p when dropping to the Linaro desktop. Just want the ES bootup to be 1080 as well.

Thanks in advance!

I'm looking into that, it seems that Debian stretch does not use the /boot/config.txt (which might be troublesome in the long run). 

Maybe try setting you tv's resolution to 1080p while we sort that out.
Swing by the: RotT FaceBook Group and join for even more help, trick, and tips.

Swing by My YouTube Channel if you get a chance.

Reply
(02-10-2018, 04:12 PM)Desproggster Wrote: what you on about boot/pwd .... it boots directly to Emulationstation ... you then launch lxde desktop from the carouselle ... it doesnt ask for a boot password or any other password ... what are you trying to do?

yes,  It boots directly to Emulstation, then I manually launch lxde desktop from the carouselle....
there IN lxde desktop: if you click in the launchbar tinkerboard settings you have the options to change boot options and tinkerboard password in the same tab. if you do, it doesn't boot properly, please check that.
I don't want to check every option to find out I have to flash the sd card again.
I don't need to reflash the sd card on regular basis.
Reply
(02-13-2018, 04:31 PM)Linker Wrote:
(02-10-2018, 04:12 PM)Desproggster Wrote: what you on about boot/pwd .... it boots directly to Emulationstation ... you then launch lxde desktop from the carouselle ... it doesnt ask for a boot password or any other password ... what are you trying to do?

yes,  It boots directly to Emulstation, then I manually launch lxde desktop from the carouselle....
there IN lxde desktop: if you click in the launchbar tinkerboard settings you have the options to change boot options and tinkerboard password in the same tab. if you do, it doesn't boot properly, please check that.
I don't want to check every option to find out I have to flash the sd card again.
I don't need to reflash the sd card on regular basis.

i do not see what your issue is or what you are doing

[Image: ROTT_1_Logo.png]
Reply
(02-13-2018, 09:50 PM)Desproggster Wrote:
(02-13-2018, 04:31 PM)Linker Wrote:
(02-10-2018, 04:12 PM)Desproggster Wrote: what you on about boot/pwd .... it boots directly to Emulationstation ... you then launch lxde desktop from the carouselle ... it doesnt ask for a boot password or any other password ... what are you trying to do?

yes,  It boots directly to Emulstation, then I manually launch lxde desktop from the carouselle....
there IN lxde desktop: if you click in the launchbar tinkerboard settings you have the options to change boot options and tinkerboard password in the same tab. if you do, it doesn't boot properly, please check that.
I don't want to check every option to find out I have to flash the sd card again.
I don't need to reflash the sd card on regular basis.

i do not see what your issue is or what you are doing

Wait, Linker are you trying to have it boot to the desktop, instead of Emulationstation? You'll have to change quite a few settings, and if your changing the host name and or the user name that might cause issues too. Why don't you tell me what you are trying to do and I can walk you through it. 

Also if you want to make your own image let me know I'll get you the one liner I made that grabs all the Dependencies for you.

Side note i'll probably remove the desktop entirely since we now can access all the stuff via retropie menu. wifi etc.
Swing by the: RotT FaceBook Group and join for even more help, trick, and tips.

Swing by My YouTube Channel if you get a chance.

Reply
(02-13-2018, 04:25 PM)Crash Wrote: Now comes the daunting task of setting up the emulator configs.  This is RotT v0.6.5
 


(02-13-2018, 04:16 PM)Vruasix Wrote: I spent 6hrs on this last night, but is there a way to force the TB to output 1080@60fps on a 4k screen, I tried adding the option in config.txt in the /boot dir but it still boots up in 4k everytime. It boots up to Emulation station in 4k but drops to 1080p when dropping to the Linaro desktop. Just want the ES bootup to be 1080 as well.

Thanks in advance!

I'm looking into that, it seems that Debian stretch does not use the /boot/config.txt (which might be troublesome in the long run). 

Maybe try setting you tv's resolution to 1080p while we sort that out.

Sadly I have no way to force my TV resolution to 1080p, I am going to do some research into the Debian Stretch boot process and see if I can find its boot config file to change the parameters. I'll let you know if I find anything this could potentially be disastrous for those of us with 4k tv's. Not to mention no working overclocks until we figure this out.
Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)