This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RetroPie on the Tinker Board
(06-06-2018, 09:31 PM)nex86 Wrote: I've been having issues setting up my Xbox 360 or Logitech F710 Controller (both same the same issue)
When I get to the Shoulder Buttons and press one it jumps to the next one assigning nothing or something else.
I don't have this issue on the Raspberry Pi. Only on Tinkerboard.

Is there a fix for this anytime soon?



Hi guy 
I have the same problem
The issue is to finish the configuration and after assign the shoulder button at the end and make a restart of émulation 
It s good for me
Reply
Good news I have a beta image with extra controller support. I will be finishing it up and making two fresh images. A new basic image and a new ROTT 1.0.4s. I should be done with in a week or two.
Swing by the: RotT FaceBook Group and join for even more help, trick, and tips.

Swing by My YouTube Channel if you get a chance.

Reply
Tinker Board (s) RetroPie SD Card/emmc install DIY

I have to take some time off to deal with some stuff. Don’t worry I’ll be back.

Thanks to the ROTT team: Crash; Steven D.; Jyo Ho; Myari; Chuck P.; Cory T.; Paint Toad; and Ntemis.

Let’s get to it.
Here is the base image with controller support download. Unzip if needed.

https://www.dropbox.com/s/albuzuhq4tqihm...5.img?dl=0

EMMc: Plug your Tinkerboard S into your pc and write to it with win32diskimager or etcher. Once done unplug and move to your tv. Sometimes at first boot the screen will be black.

SD Card: put your SD Card into your PC and write to it with win32diskimager or etcher. Once finished put it in your Tinker Board, and set it up on your tv. Sometimes at first boot the screen will be black.

That’s ok, just SSH in as root and copy and paste the lines below.

Open up putty

Host: tinkerboard
User: root
Password: 1234

Follow on screen prompts. Log in as root and Setup new user. I suggest pi so you can use some stuff from you pi3b/b+ setups. Though you can name it what you want if you do not use pi make a symbolic link to pi from your user name. Change <user> to what you chose.

cd .. && sudo ln -s /home/<user> /home/pi

After user setup switch to new user and get the setup.sh

su pi

Or

su <user>

Get the Modified setup.sh

wget https://raw.githubusercontent.com/MySora...r/setup.sh

Don’t forget to to make it so any user can use it (777) and make it executable (a+x)

sudo chmod 777 setup.sh
sudo chmod a+x setup.sh

Now Run it

./setup.sh

Or

bash setup.sh

Then follow the on screen prompts

For extended controller programs, drivers, etc

sudo apt-get install joystick joy2key jstest-gtk qjoypad xinput

Reboot

Ssh in again this time use your <user> and password you entered.

sudo ~/RetroPie-Setup/retropie_setup.sh

EMMc: go to manage packages -> Core packages ->
Install all from source

After that install ppsspp from optional packages then go back to main packages and install them all.
The reason we do it this way is because ppsspp takes around 10gb to compile. Once it’s done it’s less than a gb. Also note not all emulators will install. If they don’t remember to clear the source folder to remove the wasted space from that temp build folder.

SD Card bigger than 16gb: basic install is fine.

Install extra emulators
Note: some emulators will not install. ppsspp needs like 10gb to compile from source

Install drivers for controllers if needed. Manage packages-> drivers-> <what you need>
Xpad is always good to have. There is also a Xbox driver and a PS3 driver. The PS3 driver works. I use them on my Tinker Board.

Don’t forget to go into configuration/tools -> boot options -> And set emulationstation to start at boot.

Reboot.

You will be greeted by the controller setup after reboot. Enjoy.


Additional notes:

Use armbian-config To set up WiFi

sudo armbian-config

I suggest you set the run-command to performance. RetroPie setup -> mandage packages -> core -> runcommand -> cpu -> set for performance.

Splash screens are not part of the the supported set up. But you can install them with a few little tricks I found.

Snowy screen. SSH and update while connected to the screen you are using make sure Tv is on.

sudo apt-get update && sudo apt-get -y upgrade

Reboot

Tank your build and want to re-flash the eMMc?

Refer to your manual and get the Tinker 2.0.7 os from Asus.
Write the image to an sd card, switch the jumper to eMMc recovery. Boot device by plugging it into the pc. This should reset your eMMc and you can write to it again.
I then used a partition tool to repartition and formatted to fat32. Then I unplugged it and removed the sd card. Plugged it back in to my pc and rewrote the eMMc with win32diskimager. Refer to other online sources from Asus on this subject I only did it once.

—————————————————
If I get more time I will make a few more posts about splash screens scripts and more.
Swing by the: RotT FaceBook Group and join for even more help, trick, and tips.

Swing by My YouTube Channel if you get a chance.

Reply
is there a prebuild image I can use with the latest version?
for some reason the script cancels at some point with errors, mainly due to wget getting 404 errors.
I believe my network connection isn't that stable, even with LAN i still lose connection from time to time, only happens with tinkerboard, its fine with the pi or other devices.
Reply
Hello everybody,

I've  been playing around with Retropie on a RPi3b for a few months and decided to start a new project with a Tinker Board. MickMake inspired me to make a retro gaming station with a built in projector (mickmake dot com website -> ./post/build-a-pi-zero-w-pocket-projector-project). However, his instructions are meant for the Pi.

Part of the instructions is adding a few lines to /boot/config.txt, wich is not used by the TinkerBoard. I was wondering if there is a similiar file available on the ROTT image. Also I wonder if the code itself is usable on a Tinker Board.

# Added to support DLP2000
dtoverlay=i2c-gpio,i2c_gpio_sda=23,i2c_gpio_scl=24,i2c_gpio_delay_us=2

dtoverlay=dpi18
overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0
framebuffer_width=854
framebuffer_height=480
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87

dpi_output_format=458773
hdmi_timings=854 0 14 4 12 480 0 2 3 9 0 0 0 60 0 32000000 3


I found some instructions on another forum in a different context, saying "As for configuration, Tinkerboard is not a PI clone and does not use config.txt. Additional boot configuration can be done in extlinux.conf, you will find it in the boot partition in a directory called extlinux."  This did not help my any further, as the ROTT image doesn't use Extlinux (if i'm not mistaken). I did spot the Eslinux folder, but it seems to be empty.

Thanks a lot in advance,
Coen
Reply
Crash, thanks for those instructions, they worked beautifully and I am finally playing (essentially) full speed N64 on my single-board as was my goal....

How can I use kodi on that build? I installed it from the terminal and tried to set it to auto launch to kodi, but the autolaunch fails and then defaults to emulationstation and if i try to launch kodi from the terminal it fails.
Reply
Hello everyone:

First, I have several questions regarding Crash's instructions above. Keep in mind I bought a Tinker Board for several reasons, including learning both Unix / Linux command lines as well as other things , including retro things like this. I have not actually used a direct command line system since I was a child on my father's old KayPro II, so bear with me.

First and foremost: While Crash is some kind of brilliant person I am certain, I simply have not been able to follow his directions on this. Setting up the new user is simple enough on the image listed above, though, the tinker board itself often misscommunicates with the TV I am using it on, and as such, the resolution is vastly too large and the command line itself is off screen to the bottom. But even when, after all that I am capable of seting up a new user, and even connecting via WiFi, I simply hit a dead end at that point.

"sudo ~/RetroPie-Setup/retropie_setup.sh" Simply does not seem to exist, even though I think I downloaded that update, and I cannot seem to access any type of file list or directory to guide me.

I cannot progress beyond there.

Keep in mind, while I am fully aware of the existence of some kind of facebook group, I shall never join, as I permanently left FB after their refusal to act on both the Rohingya and Sri Lankan crises. Indeed, I have a friend on the ground in Sri Lanka and they attest to the complicity of FB. As such, it will never be that I seek guidance from that group.

To be frank, I am not certain that "wget githubusercontent" page downloads properly. Nor that I enable 777 and a+x properly. I would like further instructions. Or, failing that, perhaps I would like your opinion or other alternatives.

Thank you in advance.
Reply
Hi everyone,

I just followed the instructions from Crash and could be able to get a working retropie on my tinkerboard (not the version S).  I used a 32GB microSD card and could create a image file of it. The image file is unfortunately big and I couldn't resize it.
I don't know, if you can use this image, but I uploaded the file on my owncloud server. Here is the link for the image file:

https: //waltikon.mooo.com/index.php/s/ukiE2evo4Sp6hM3

Please, do not ask me anything about the image file, because I am a real noobie. If someone can get the image file smaller,  please let me know. We can share than the smaller file.

PS: Finally, I could resize the img file. I don't know, if it is working, but you can find the file here:

https: //waltikon.mooo.com/index.php/s/aKUhbBEkNFP0n9a

Password for the users root and pi: tinkerboard
Reply
Hi all, tell me please how i can change wayland to xserver with xinit in this script "wget https: //raw.githubusercontent.com/MySora/Armbian-Setup-for-RetroPie/master/setup.sh "
Reply
Hi all,

I got my first Tinker Board S yesterday and so for only tested Kodi on it, which works great but I'd like to see how it handles Retropie.

I tried the Debian on PC install method from the official Retropie site but couldn't install it. I am unable to download Armbian_5.50_Tinkerboard_Debian_stretch_default_4.4.135 from post #186 of this thread and have tried to use ROTT v1.0.3s.img on two different SD cards (8 & 64 GB) but I only get a black screen. I am unable to SSH to the device. The hostname says it doesn't exist and the only new IP I don't recognise on the network refuses the connection.

Is there a simple way to get RetroPie working on the S version of this board?

Thanks.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)