This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Stop annoying RT871X not linked messages on T-OS1.8 without X
#1
Hello,

I try to use tinkerboard with eglfs without X11 to compile and use Qt5.x with accelerated Video/GPU as described here:

Compile Qt eglfs on tinker

My Problem is when stop booting in X with systemctl set-default multi-user.target I get messages like:
RT871X not linked power save enter
RT871X not linked power save leave
RT871X not linked power save enter
RT871X not linked power save leave
etc etc ...

in command line

I know that it is possible to stop this powering off the chip, but I want to use WiFi:

So if I setup Wifi via wpa_supplicant.conf manually or with tinker-config some more messages starts floading screen which makes it practically inpossible to work on command line. That's extremly annoying.

Tty-change via Alt-F2 don't help.

I think that there must be a way to route this into a log file or stopping, but I don't now how?

btw. A Tinker OS light without GUI would be cool. DietPi is not a solution cause there are no GPU/VPU-accelerations.

Kind regards
M.



edit:
I do not know if it this is elegant, but I solved it!
sudo dmesg -n 1
stops messaging on screen and to do it for each boot put this it in /etc/rc.local

Kind regards
M.
Reply
#2
(08-30-2017, 02:18 PM)mechtor Wrote: Hello,

I try to use tinkerboard with eglfs without X11 to compile and use Qt5.x with accelerated Video/GPU as described here:

Compile QT eglfs on tinker

My Problem is when stop booting in X with systemctl set-default multi-user.target I get messages like:
RT871X not linked power save enter
RT871X not linked power save leave
RT871X not linked power save enter
RT871X not linked power save leave
etc etc ...

in command line

I know that it is possible to stop this powering off the chip, but I want to use WiFi:

So if I setup Wifi via wpa_supplicant.conf manually or with tinker-config some more messages starts floading screen which makes it practically inpossible to work on command line. That's extremly annoying.

Tty-change via Alt-F2 don't help.

I think that there must be a way to route this into a log file or stopping, but I don't now how?

btw. A Tinker OS light without GUI would be cool. DietPi is not a solution cause there are no GPU/VPU-accelerations.

Kind regards
M.



edit:
I do not know if it this is elegant, but I solved it!
sudo dmesg -n 1
stops messaging on screen and to do it for each boot put this it in /etc/rc.local

Kind regards
M.

I also run into same annoying messages on console. makes console useless. I also used "dmesg -D" to disable console logging.

BTW, were you able to successfully compile / run by following article "Compile QT eglfs on tinker" ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)