This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
wiringPi for Android
#31
(10-22-2018, 12:15 PM)lobo Wrote: I tried now to integrate the serial part into an app and it works so far. I think you missed to chmod the serial port:
Code:
chmod 666 /dev/ttyS1
If you need this at start, I see the only working solution so far to extract the boot.img and to modify the ueventd.rk30board.rc.

Hi lobo!

I use same method from http s://tinkerboarding.co.uk/forum/thread-671.html
And add next line
Code:
/dev/ttyS1                0660   system  system
# also i try 0666 value, but without success result.
to ueventd.rk30board.rc.

But without command
Code:
chmod 666 /dev/ttyS1
in adb wiringPi not works.

Android M V13.13.0.74.

Note:
I copy file from my TB to desktop
Code:
adb pull ueventd.rk30board.rc /Users/user/Desktop/test
and it contains my line with correct permission for /dev/ttyS1
Reply
#32
Then show please what shows 'ls -la /dev/ttyS1' directly after reboot. Maybe another method is setting the permission back?

[EDIT]
A quick search:
Code:
grep -r "/dev/ttyS1" .
./init.connectivity.rc:    chmod 0660 /dev/ttyS1
./init.connectivity.rc:    chown bluetooth net_bt_stack /dev/ttyS1
Maybe this is making this. Try to remove this lines from 'init.connectivity.rc' and lets see if it works.
[-] The following 1 user Likes lobo's post:
  • fited
Reply
#33
(02-12-2019, 05:07 PM)lobo Wrote: Then show please what shows 'ls -la /dev/ttyS1' directly after reboot. Maybe another method is setting the permission back?

[EDIT]
A quick search:
Code:
grep -r "/dev/ttyS1" .
./init.connectivity.rc:    chmod 0660 /dev/ttyS1
./init.connectivity.rc:    chown bluetooth net_bt_stack /dev/ttyS1
Maybe this is making this. Try to remove this lines from 'init.connectivity.rc' and lets see if it works.

Wow, i didn't even think about it! Most likely the issue in this overrides.
I will try in 10 hours and post results! I forget device at home.
Thank you very much for answer!
[-] The following 1 user Likes fited's post:
  • fited
Reply
#34
(02-12-2019, 05:07 PM)lobo Wrote: Maybe this is making this. Try to remove this lines from 'init.connectivity.rc' and lets see if it works.
Yes, after i remove this lines, all works perfectly! You rock! Thank you very much again!!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)