This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Volume control for hdmi output
#1
I'm using TinkerOS 2.01 (Mikerr's version). Sound output to hdmi works fine. I can control the volume via  PulseAudio, but not the volume control on taskbar. The latter seems to only control audio jack output, same as the volume control key on  my keyboard. It's a minor inconvenience, but I'm wondering if anyone has found a way to use them to control hdmi sound volume?
Reply
#2
(09-24-2017, 04:35 PM)qaplus Wrote: I'm using TinkerOS 2.01 (Mikerr's version). Sound output to hdmi works fine. I can control the volume via  PulseAudio, but not the volume control on taskbar. The latter seems to only control audio jack output, same as the volume control key on  my keyboard. It's a minor inconvenience, but I'm wondering if anyone has found a way to use them to control hdmi sound volume?

Hi qaplus:

The volume control depends on what PulseAudio default sink when it starts , you can set default sink at /etc/pulse/default.pa:

set to HDMI
set-default-sink alsa_output.platform-sound-simple-card.analog-stereo

set to 3.5mm
set--default-sink alsa_output.hw_0_2

After setting, you MUST restart PulseAudio:
pulseaudio --kill
pulseaudio --start

Thanks,
Angus
Reply
#3
Thanks Angus. It's working now.

Previously, mine was somehow set to 'set-default-sink alsa_output.platform-sound.analog-stereo'.
Reply
#4
This did not work for me :Sad I am using the latest download and the newest tinker board s.

Any ideas?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)