This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
missing i2c module
hello all,

would someone give me a hand with a missing i2c_rk3x_i2c1 module? after installing GPIO_API_for_C and using gpio load i2c [100], i get:

linaro@linaro-alip:~$ sudo gpio load i2c [100]
modprobe: FATAL: Module i2c_rk3x_i2c1 not found in directory /lib/modules/4.4.71+
gpio: Unable to load i2c_rk3x_i2c1

if i enter the unload command. i get:

linaro@linaro-alip:~$ gpio unload i2c
gpio: Unable to load/unload modules as this Pi has the device tree enabled.
  You need to run the raspi-config program (as root) and select the
  modules (SPI or I2C) that you wish to load/unload there and reboot.
  There is more information here:

... which i am reading now ..

i don't yet know anything about a device tree, im new to linux and i haven't played with a raspberry pi yet.

i have had the same error on tinkerOS 1.8, 2.0 and mikerrs 2.0.1

there was also i decent youtube video i followed here:

still no module though.

i haven't found anything on google or this forum yet. im about to go through the videos steps again just for fun

thanks in advance,

the raspberrypi forums solution is to edit a "raspi-config", and understandably isn;t appearing on tinkerOS. is there an asus equivalent?

it may be equivalent to the /etc/modules test file that the video shows...
i2c advance option in tinker-config is not active., no matter what I try, edit etc modules and boot config nothing work for me.
(10-29-2017, 05:12 AM)Hunster22 Wrote: i2c  advance option in tinker-config is not active., no matter what I try, edit etc modules and boot config nothing work for me.
This is very old post, But I just want to ask. How did you edit your etc modules to enable I2C? I'm stuck on.
I guess you haven't search much, because if you did you could find something like this
Light blue words might be a link. Have you try to click on them? Big Grin

Forum Jump:

Users browsing this thread: 1 Guest(s)