This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB serial console on the Tinker Board
#1
Hello  Smile

I have a Prolific PL2303 USB to serial converter that I've successfully used in the past to access a Raspberry Pi 3's console on my mac. I however, can't access the Tinkerboard's console in the same way. Are there any configuration files that I need to edit or options I need to change somewhere to get this to work?

Currently, after plugging the USB to TTL into my mac, I run:

Code:
screen /dev/cu.usbserial 115200

and I simply get a blank screen.
  • Yes, my USB to TTL works, I've tested this on my Raspberry Pi a day ago
  • Yes, I see this device in my mac's "System report" under "USB"
  • Running Tinker OS 1.4
Appreciate the help.

Cheers!
Reply
#2
(04-04-2017, 12:00 PM)nav Wrote:
  • Yes, my USB to TTL works, I've tested this on my Raspberry Pi a day ago
  • Yes, I see this device in my mac's "System report" under "USB"
  • Running Tinker OS 1.4

First, I hope not TTL (TTL is 5V logic and you need level shifter to 3.3V CMOS logic) (see H/W considerations).
Second, there is no activity on serial line after u-boot kernel load (name uart1, hw device serial@ff190000, device /dev/ttyS1, on connector pins 8+10) until you added some application on TinkerBoard side OR you enabled kernel serial output in kernel boot configuration (u-boot goes automatically to this serial @115200), check it (must contain "console=ttyS1,115200n8", secondary console tty1 makes output to hdmi display)
Code:
# cat /boot/extlinux/extlinux.conf
label kernel-4.4
    kernel /zImage
    fdt /rk3288-miniarm.dtb
    append earlyprintk console=ttyS1,115200n8 console=tty1 root=/dev/mmcblk0p2 rw init=/sbin/init

After reboot you should see something like this on serial line:
Code:
cap 2048
chipsize_mb=1024
chipsize_mb=1024
size_mb = 2048


U-Boot 2016.09-rc1 (Feb 23 2017 - 17:59:51 +0800)

Model: Miniarm-RK3288
DRAM:  chipsize_mb=1024
chipsize_mb=1024
size_mb = 2048
2 GiB
MMC:   dwmmc@ff0c0000: 0
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   Net Initialization Skipped
No ethernet found.
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found /extlinux/extlinux.conf
Retrieving file: /extlinux/extlinux.conf
reading /extlinux/extlinux.conf
160 bytes read in 9 ms (16.6 KiB/s)
Retrieving file: /hw_intf.conf
reading /hw_intf.conf
109 bytes read in 6 ms (17.6 KiB/s)
hw_conf.valid = 1
hw_conf.i2c1 = 1
hw_conf.i2c4 = 1
hw_conf.spi2 = 1
hw_conf.pwm2 = 1
hw_conf.pwm3 = 1
hw_conf.uart1 = 1
1:    kernel-4.4
Retrieving file: /zImage
reading /zImage
6939552 bytes read in 540 ms (12.3 MiB/s)
append: earlyprintk console=ttyS1,115200 console=tty1 root=/dev/mmcblk0p2 rw init=/sbin/init uboot_version=2016.09-rc1
Retrieving file: /rk3288-miniarm.dtb
reading /rk3288-miniarm.dtb
45592 bytes read in 14 ms (3.1 MiB/s)
## Flattened Device Tree blob at 01f00000
  Booting using the fdt blob at 0x1f00000
  Loading Device Tree to 1fff1000, end 1ffff617 ... OK

Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0x500
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Initializing cgroup subsys cpuacct
[    0.000000] Linux version 4.4.16 (root@tinker1) (gcc version 6.3.0 20170321 (Debian 6.3.0-11) ) #2 SMP Sat Apr 8 19:40:12 UTC 2017
[    0.000000] CPU: ARMv7 Processor [410fc0d1] revision 1 (ARMv7), cr=10c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] Machine model: rockchip,rk3288-miniarm
[    0.000000] cma: Reserved 128 MiB at 0x78000000
[    0.000000] Memory policy: Data cache writealloc
[    0.000000] PERCPU: Embedded 13 pages/cpu @eef8d000 s24216 r8192 d20840 u53248
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 522752
...
[  OK  ] Started LSB: Advanced IEEE 802.11 management daemon.
        Starting Hold until boot process finishes up...
        Starting Terminate Plymouth Boot Screen...

Debian GNU/Linux 9 tinker1 ttyS1

tinker1 login: root (automatic login)

Last login: Sun Apr 16 09:18:57 UTC 2017 on ttyS1

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
root@tinker1:~#

WARNING: Be aware of other builds of u-boot (see https://github.com/rockchip-linux/u-boot...config#L62) and kernel/distributions (for example https://github.com/rockchip-linux/build). It usually defaulting console to serial 2 (name uart2, hw device serial@ff690000, device /dev/ttyS2, on connector pins 32+33) and it is overlapped with PWM2 and PWM3 functionality !
I left this community in Aug 2017 due to bad product quality and community support that did not match my expectation.  Sad
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)