This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
autofs4 not set in kernel
#1
Hi @all

I need autofs for mounting several filesystems on demand (cifs,nfs,usb..) but the module seems to be disabled in the kernel.
TinkerOS_Debian V1.6 (Beta version)

Code:
root@linaro-alip:~# zcat /proc/config.gz | grep AUTOFS
# CONFIG_AUTOFS4_FS is not set
root@linaro-alip:~#

So the installation fails.

Code:
root@linaro-alip:~# apt-get install autofs
Reading package lists... Done
Building dependency tree
Reading state information... Done
Recommended packages:
 nfs-common
The following NEW packages will be installed:
 autofs
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
Need to get 0 B/271 kB of archives.
After this operation, 1155 kB of additional disk space will be used.
Selecting previously unselected package autofs.
(Reading database ... 56851 files and directories currently installed.)
Preparing to unpack .../autofs_5.0.8-2+deb8u1_armhf.deb ...
Unpacking autofs (5.0.8-2+deb8u1) ...
Processing triggers for systemd (230-7~bpo8+2) ...
Setting up autofs (5.0.8-2+deb8u1) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Job for autofs.service failed because the control process exited with error code.
See "systemctl status autofs.service" and "journalctl -xe" for details.
invoke-rc.d: initscript autofs, action "start" failed.
dpkg: error processing package autofs (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
autofs
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@linaro-alip:~#

/var/log/syslog message :
Code:
Apr  5 16:04:36 linaro-alip autofs[2708]: Starting automount...failed (failed to load autofs4 module).
Apr  5 16:04:36 linaro-alip systemd[1]: Failed to start LSB: Automounts filesystems on demand.
Apr  5 16:04:36 linaro-alip systemd[1]: autofs.service: Failed with result 'exit-code'.

Any suggestions for that problem?

THX
Reply
#2
Seems to be fixed in TOSv1.8

Thanks a lot

Big Grin
Reply
#3
(04-21-2017, 05:38 PM)Psycho_Dad Wrote: Seems to be fixed in TOSv1.8

Thanks a lot

Big Grin

Have You managed to start autofs? At TOSv1.8 I still get:


Code:
Apr 21 20:32:00 linaro-alip automount[7697]: /usr/sbin/automount: test mount forbidden or incorrect kernel protocol version, kernel protocol version 5.00 or above required.
Apr 21 20:32:00 linaro-alip systemd[1]: Failed to start Automounts filesystems on demand.
Apr 21 20:32:00 linaro-alip systemd[1]: autofs.service: Failed with result 'exit-code'.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)