This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
libGL error: unable to load driver: rockchip_dri.so
#1
I'm getting this error when I try to load mame:

libGL error: unable to load driver: rockchip_dri.so

The software still runs, but is unusably slow. I can't make it do anything.

What error is this, and what can I do to fix it, please?
Reply
#2
(01-30-2018, 08:23 PM)Annoying Twit Wrote: I'm getting this error when I try to load mame:

libGL error: unable to load driver: rockchip_dri.so

The software still runs, but is unusably slow. I can't make it do anything.

What error is this, and what can I do to fix it, please?

LIBGL_ALWAYS_SOFTWARE=1 glxgears
Reply
#3
(01-31-2018, 02:54 AM)engineer_on_holiday Wrote: LIBGL_ALWAYS_SOFTWARE=1 glxgears

Thanks. Embarrassingly I only got around to trying this today. I expected that this would turn off hardware rendering and slow it down, but I get about 200fps on GlxGears without or without the flag. I don't know if this means that I'm not getting accellerated OpenGL on glxgears always, or whether the flag has not turned it off.

Mame is now responsive, though I have to work out now how to tell it where my libraries are. Off to google.
Reply
#4
(02-04-2018, 10:58 AM)Annoying Twit Wrote:
(01-31-2018, 02:54 AM)engineer_on_holiday Wrote: LIBGL_ALWAYS_SOFTWARE=1 glxgears

Thanks. Embarrassingly I only got around to trying this today. I expected that this would turn off hardware rendering and slow it down, but I get about 200fps on GlxGears without or without the flag. I don't know if this means that I'm not getting accellerated OpenGL on glxgears always, or whether the flag has not turned it off.

Mame is now responsive, though I have to work out now how to tell it where my libraries are. Off to google.

This error message is caused by the userspace application try to use the OpenGL API.
However, Tinker Board can only support OpenGL ES but not OpenGL API.
So you need to use the OpenGL-ES API instead of OpenGL.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)